Event ID - 204

Event Id204
SourceActive Directory Rights Management Services
DescriptionActive Directory Rights Management Services (AD RMS) was not able to retrieve the certificate hierarchy.
Event InformationAccording to Microsoft :
Cause :
This event is logged when Active Directory Rights Management Services (AD RMS) was not able to retrieve the certificate hierarchy.
Resolution :
Create AD RMS hierarchy registry entry
Two certificate hierarchies are supported by AD RMS: Production and ISV. You should use the Production hierarchy, except in special scenarios such as when you are developing an AD RMS-enabled application and want to be in the ISV hierarchy. If the certificate hierarchy cannot be determined during the installation of AD RMS, the installation will fail. You must create the hierarchy key, assign it the correct value, and then install AD RMS again.
Note :
To perform these procedures, you must be a member of the local Administrators group, or you must have been delegated the appropriate authority.
Create the AD RMS hierachy registry key
To create the AD RMS hierachy registry key:
1.On the computer where you are installing AD RMS, clickStart.
2.In theStart Search box, typeRegedit, and then press ENTER.
3.Navigate toHKEY_LOCAL_MACHINE\Software\Microsoft\uDRM.
4.Right-clickuDRM, point to New, and then clickDWORD (32-bit) Value.
5.Name the registry entryHierarchy.
6.Right-clickHierarchy, and then clickModify.
7.Type 0, and then click OK.
Install the AD RMS role by using Server Manager
To install the AD RMS role by using Server Manager:
1.ClickStart, point toAdministrative Tools, and then clickServer Manager.
2.In the Roles Summary section, clickAdd Roles, and then clickNext.
3.Select theActive Directory Rights Management Services check box, and then clickNext.
4.Complete the appropriate information in the AD RMS role wizard setup.
5.Click Install.
6.When the installation is complete, clickClose.
Verify :
To perform this procedure, you must be a member of the local AD RMS Enterprise Administrators group, or you must have been delegated the appropriate authority.
To verify that the AD RMS cluster installation is working properly:
1.Log on to a server in the AD RMS cluster.
2.ClickStart, point to Administrative Tools, and then click Active Directory Rights Management Services.
3.Verify that the AD RMS cluster was added successfully by expanding the AD RMS cluster name.
Reference LinksEvent ID 204 from Source Active Directory Rights Management Services

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