Event ID - 90

Event Id90
SourceMicrosoft-Windows-CertificationAuthority
DescriptionActive Directory Certificate Services detected an exception at address %2. Flags = %3. The exception is %4.
Event InformationAccording to Microsoft :
Cause
This event is logged when Active Directory Certificate Services detected an exception at address.
Resolution
Restart the certification authority
To perform this procedure, you must have Manage CA permission, or you must have been delegated the appropriate authority.
To correct the service shutdown:
1.On the computer hosting the CA, click Start, point to Administrative Tools, and click Services.
2.Locate the
Active Directory Certificate Services (AD CS) service.
3.Confirm that AD CS is not running, and then attempt to restart the service.
4.If the service does not start, restart the computer, then try to restart AD CS again.
5.If the problem is not resolved, you can use the following procedures, Create a debug log and Enable CryptoAPI 2.0 Diagnostics, to compile information that will be useful if you need to contact Microsoft Customer Service and Support.
Create a debug log
To create a debug log:
1.On the computer hosting the CA, click Start, type cmd and press ENTER.
2.Type certutil -setreg ca\debug 0xffffffe3 and press ENTER.
3.Click Start, point to Administrative Tools, and click B>Services.
4.Select the Active Directory Certificate Services service, and click Start.
5.When you have reproduced the issue, locate the certsrv.log file containing advanced diagnostic information in the %windir% directory.
6.When you have finished generating the diagnostics, disable debugging by opening a command prompt window.
7.Type certutil -delreg ca\debug and press ENTER.
Enable CryptoAPI 2.0 Diagnostics
To enable CryptoAPI 2.0 Diagnostics:
1.On the computer hosting the CA, click Start, point to Administrative Tools, and click Event Viewer.
2.In the console tree, expand Event Viewer, Applications and Services Logs, Microsoft, Windows, and CAPI2.
3.Right-click Operational, and click Enable Log.
4.Click Start, point to Administrative Tools, and click Services.
5.Right-click Active Directory Certificate Services, and click Restart.
Verify
To perform this procedure, you must have membership in local Administrators on the computer hosting the certification authority (CA), or you must have been delegated the appropriate authority.
To confirm that the CA service is available:
1.On the computer hosting the CA, click Start, type cmd and press ENTER.
2.Type certutil -config -ping and press ENTER.CAconfig is the CA configuration string, in the form CAhostname\CAname.
Reference LinksEvent ID 90 from Source Microsoft-Windows-CertificationAuthority

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