Event ID - 8229

Event Id8229
SourceMicrosoft-Windows-IDMU-ServerForNIS
DescriptionPushThread creation failed.
Event Information According to Microsoft :

Cause :

This event is logged when pushthread creation failed.

Resolution :

Close some applications and restart Server for NIS

A server thread creation failure occurred. This can occur if the Windows operating system is running low on virtual memory, or if the server's performance or health is significantly degraded. Close unused applications, or close all applications and restart Server for NIS. If that fails to correct the problem, close all applications and restart the server.

Restart Server for NIS by using the Windows interface

To restart Server for NIS by using the Windows interface:
  1. Open the Identity Management for UNIX management console.
  2. If necessary, connect to the computer you want to manage.
  3. Right-click Server for NIS , and then click Stop .
  4. Right-click Server for NIS again, and then click Start .
To restart Server for NIS by using a command line:
  1. Open a Command Prompt window.
  2. Type the following, and then press ENTER.

    • nisadmin [server] stop [–u user [–p password]]

  3. Type the following, and then press ENTER.

    • nisadmin [server] stop [–u user [–p password]]

For more information, see the topic "Start or stop Identity Management for UNIX components" in the Identity Management for UNIX Help.

To restart the computer:
  • Click Start , click the arrow next to the Lock button, and then click Restart .
Verify :

Open the Services MMC and verify that Server for NIS is operational. If the Server for NIS service properties show that the service is not running, errors are preventing Server for NIS from operating normally.

To verify that Server for NIS is running
  1. Click Start , point to Administrative Tools , and then click Services .
  2. In the Results pane of the Services MMC, double-click Server for NIS .
  3. In the Service status area of the Server for NIS Properties dialog box, verify that the Server for NIS service shows as Started.
Use the ypcat command on a client computer in the domain on which the error was generated to verify that the Server for NIS service is available.

To use the ypcat command to verify Server for NIS service availability:
  1. On a client computer in the domain on which the error was generated, open a Windows Command Prompt with elevated privileges. To do this, right click Command Prompt on the Start menu, and then click Run as administrator .
  2. Type the following command, and then press Enter: ypcat -h NISServer- d Domain Mapname. NISServer represents the name of the server on which you want to verify that the Server for NIS Service is available. Domain represents the domain name on which you want to verify that the Server for NIS service is available. Mapname represents the name or nickname of a specific NIS map that the server on which you want to verify Server for NIS availability is expected to update.
  3. If you are prompted to provide the domain administrator account name and password, type the account name and password, and then press Enter .
  4. The ypcat Windows command-line utility prints the values of all keys from the NIS database specified by Mapname, which can be a map name or a map nickname. If the ypcat utility returns a list of key values for the maps you specified, the Server for NIS service is available.
Reference LinksEvent ID 8229 from Microsoft-Windows-IDMU-ServerForNIS

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