Event ID - 81

Event Id81
SourceMicrosoft-Windows-TerminalServices-Licensing
DescriptionThe Terminal Services client access license (TS CAL) issued to "%1" could not be revoked because the revocation limit for the product "%2" is reached. %3 of the installed %4 TS CALs are already revoked. The TS CAL revocation of this product type will be allowed after %5.
Event InformationAccording to Microsoft :
Cause :
This event is logged when Terminal Services client access license (TS CAL) issued to could not be revoked because the revocation limit for the product is reached.
Resolution :
Install additional TS Per Device CALs or wait until the date specified
To resolve this issue, do either of the following:
  • Install additional Terminal Services Per Device client access licenses (TS Per Device CALs) onto the Terminal Services license server.
  • Wait until the date specified to revoke additional TS Per Device CALs.
In Windows Server 2008, you can revoke TS Per Device CALs by using TS Licensing Manager. However, only a certain percentage of TS Per Device CALs can be revoked during a particular time period. Since the revocation limit is based on a percentage of TS Per Device CALs installed, installing additional TS Per Device CALs will increase the revocation limit and you will be able to revoke additional TS Per Device CALs if necessary. If the revocation limit has been reached and you attempt to revoke a TS Per Device CAL, Event 81, with a source of TerminalServices-Licensing, will be logged in the System log, and will provide the date when you can try again to revoke a TS Per Device CAL
Install TS Per Device CALs on to the license server
Note : The automatic TS CAL installation method requires Internet connectivity from the computer running the TS Licensing Manager tool. Internet connectivity is not required from the license server itself. This method uses TCP/IP (TCP port 443) to connect directly to the Microsoft Clearinghouse. You can also install TS CALs onto the license server by using a Web browser or by the using the telephone.
To perform this procedure, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
To install TS Per Device CALs automatically:
  1. On the license server, open TS Licensing Manager. To open TS Licensing Manager, click Start, point to Administrative Tools, point to Terminal Services, and then click TS Licensing Manager.
  2. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  3. Ensure that the connection method for the Terminal Services license server is set to Automatic connection (recommended) by right-clicking the license server on which you want to install TS Per Device CALs, and then clicking Properties. On the Connection Method tab, change the connection method if necessary, and then click OK.
  4. Right-click the license server on which you want to install the TS Per Device CALs, and then click Install Licenses. The Install Licenses Wizard starts.
  5. Click Next.
  6. On the License Program page, select the appropriate program through which you purchased your TS Per Device CALs, and then click Next.
  7. The License Program that you selected on the previous page in the wizard will determine what information you will need to provide on this page. In most cases, you will have to provide either a license code or an agreement number. Consult the documentation provided when you purchased your TS Per Device CALs.
  8. After you have entered the required information, click Next.
  9. On the Product Version and License Type page, select the appropriate product version, license type, and quantity of TS CALs for your environment based on your TS CAL purchase agreement, and then click Next.
  10. The Microsoft Clearinghouse is automatically contacted and processes your request. The TS Per Device CALs are then automatically installed onto the license server.
  11. To complete the process, click Finish.
Verify :
To verify that Terminal Services client access licenses (TS CALs) are installed and available on the Terminal Services license server, use the TS Licensing Manager tool.
To perform this procedure, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
To verify that TS CALs are installed and available:
  1. On the license server, open TS Licensing Manager. To open TS Licensing Manager, click Start, point to Administrative Tools, point to Terminal Services, and then click TS Licensing Manager.
  2. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  3. In the left pane, expand All Servers, and then click the license server. In the right pane, the type, version, and number of TS CALs installed on the license server is listed.
Note : To verify that the terminal server can discover (contact) a Terminal Services license server with the appropriate type of Terminal Services client access licenses (TS CALs), use Licensing Diagnosis in the Terminal Services Configuration tool on the terminal server.
Reference LinksEvent ID 81 from Source Microsoft-Windows-TerminalServices-Licensing

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