Event ID - 640

Event Id640
SourceMicrosoft-Windows-TerminalServices-Gateway
DescriptionTS Gateway Network access Policy engine failed to contact IAS and the error was "%2"
Event InformationAccording to Microsoft :
Cause :
This event is logged when the TS Gateway Network access Policy engine failed to contact IAS and the error occurred.
Resolution :
Ensure that the Network Policy Server service is started
To resolve this issue, ensure that the Network Policy Server service is started.
To perform this procedure, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
If you have configured local Terminal Services connection authorization policies (TS CAPs), perform the following procedure on the TS Gateway server. If you have configured central TS CAPs (TS CAPs that are stored on another computer running the Network Policy Server service), perform the following procedure on the NPS server where the central TS CAPs are stored.
To ensure that the Network Policy Server service is started:
  1. On the TS Gateway server or the NPS server where the central TS CAPs are stored, click Start, point to Administrative Tools, and then click Services.
  2. In the Services snap-in, find Network Policy Server, and then confirm that Started appears in the Status column.
  3. If the status is not Started, right-click Network Policy Server, and then click Start.
  4. If the attempt to start only the service fails, restart the computer. This forces all related and dependent services to restart.
  5. If you want the service to always start automatically after the server is restarted, right-click Network Policy Server, click Properties, and in Startup type, select Automatic, and then click OK.
Verify :
To verify that the TS Gateway server is available for client connections, examine Event Viewer logs and search for the following event messages. These event messages indicate that the Terminal Services Gateway service is running, and that clients are successfully connecting to internal network resources through the TS Gateway server.
To perform this procedure, you do not need to have membership in the local Administrators group. Therefore, as a security best practice, consider performing this task as a user without administrative credentials.
  • To verify that the TS Gateway server is available for client connections:
    1. On the TS Gateway server, click Start, point to Administrative Tools, and then click Event Viewer.
    2. In the Event Viewer console tree, navigate to Application and Services Logs\Microsoft\Windows\TerminalServices-Gateway, and then search for the following events:
      • Event ID 101, Source TerminalServices-Gateway: This event indicates that the Terminal Services Gateway service is running.
      • Event ID 200, Source TerminalServices-Gateway: This event indicates that the client connected to the TS Gateway server.
      • Event ID 302, Source TerminalServices-Gateway: This event indicates that the client connected to an internal network resource through the TS Gateway server.
  • Reference LinksEvent ID 640 from Source Microsoft-Windows-TerminalServices-Gateway

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