Event ID - 2

Event Id2
SourceMicrosoft-Windows-Backup
DescriptionWindows Backup catalog is corrupt. Please recover the catalog from a backup using 'WBADMIN RESTORE CATALOG' or using Windows Backup MMC Snapin.
Event InformationAccording to Microsoft :
Cause
This event is logged when Windows Backup catalog is corrupt.
Resolution
Restore the global catalog from a recent backup
You must have a global catalog file that is not corrupted to create backups (the global catalog contains information about all your backups and backup destinations). If the global catalog file becomes corrupted, you will receive an alert and an event will be added to the event log (Event ID 2 or 514). To continue with future backups, you will need to either restore the global catalog using the catalog from a recent backup—or delete the corrupted global catalog if no backups are available. If you delete the catalog, the information about previous backups will be lost, and you will not be able to access previous backups using the Windows Server Backup snap-in.
To recover or delete a catalog, you must have membership in or Administrators, or you must have been delegated the appropriate authority.
Restore the global catalog
To restore the global catalog from a backup destination:
1.Open an elevated Command Prompt window. Click Start, point to All Programs, click Accessories, right-click Command PromptRun as administrator.
2.At the prompt, type: wbadmin restore catalog -backuptarget:.
Delete the global catalog
To delete the global catalog:
1.Open an elevated Command Prompt window. Click Start, point to All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.
2.At the prompt, type (no parameters): wbadmin delete catalog.
Verify
To verify that Windows Server Backup is able to perform backup and recovery operations, you should verify that the Block Level Backup Engine service (wbengine) is able to start and that the global catalog and the local catalog have not been corrupted. The global catalog is the file that contains information about all your backups, and the local catalog is the file that contains information about backups saved to a specific destination.Backup Operators or Administrators, or you must have been delegated the appropriate authority.
Verify that wbengine can start
To verify that wbengine can start:
Open an elevated Command Prompt window. Click Start, point to All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.
2.At the prompt, type: net start wbengine.
3.View the text message to verify that the service starts or is already started.
Verify the local catalog
To verify that the local catalog stored on a backup destination exists and is not corrupted:
1.Open an elevated Command Prompt window. Click Start, point to All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.
2.At the prompt, type: wbadmin get versions -backuptarget:.
3.Verify that command runs without errors.
Verify the global catalog
To verify that the global catalog on the boot volume exists and is not corrupted:
2.Open an elevated Command Prompt window. Click Start, point to All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator.
2.At the prompt, type (with no parameters): wbadmin get versions.Without parameters this command shows all the backups you have taken that are stored in all locations—that is, information stored in the global catalog.
3.Verify that the command runs without errors.
Reference LinksEvent ID 2 from Source Microsoft-Windows-Backup

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.