Event ID - 24

Event Id24
SourceMicrosoft-Windows-PrintSpooler
DescriptionPrinter %1 failed to initialize because none of its ports (%2) could be found. This can occur if the ports were deleted or the port information is invalid.
Event Information According to Microsoft :

Cause :

This event is logged when printer failed to initialize because none of its ports could be found.

Resolution :

Recreate the printer port

To resolve this error, recreate the printer port by performing the following steps:
  1. In the Printers folder in Control Panel or in the Print Management snap-in, right-click the affected printer and then click Properties.
  2. Click the Ports tab.
  3. If the appropriate port is not already selected, select it now and then try again to print a document.
  4. If the appropriate port is not listed on the Ports tab, click Add Port and then follow the instructions on the screen to recreate the affected port.
Verify :

To verify that the print queue is operating properly:
  1. In the Printers folder in Control Panel or in the Print Management snap-in, confirm that the status listed for the affected printer is either Ready or Printing .
  2. Send a document to the printer. Examine the printed document to confirm that it printed correctly.
    Note : If the print server logs spooler information events, Windows logs Print Spooler Event ID 10 after each successful printing operation.
Reference LinksEvent ID 24 from Source Microsoft-Windows-PrintSpooler

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.