Event ID - 2064

Event Id2064
SourceMSMQ
DescriptionThe transactions checkpoint file failed to initialize. The file MQTrans.lg1 or MQTrans.lg2 in the Msmq\Storage folder are corrupted or absent. Error %1: %2
Event InformationAccording to Microsoft :
Cause :
This event is logged when the transactions checkpoint file failed to initialize.
Resolution :
Delete transaction checkpoint files
Checkpoint files must be available for Message Queuing to function properly. To resolve this issue, you must delete the transaction checkpoint files, as well as the QMLog file in the Message Queuing storage directory. This can result in some messages being duplicated. However, this resolution will get the service running as soon as possible and usually without data loss.
To perform these procedures, you must have membership in Administrators, or you must have been delegated the appropriate authority.
Delete checkpoint files
To delete checkpoint files:
Caution: Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.
1.Open Windows Explorer and browse to your storage directory. This is typically located under C:\Windows\System32\msmq\storage.
2.Delete the following files: MQTrans.lg1, MQTrans.lg2, and QMLog file.
3.Open the Registry Editor. To open Registry Editor, click Start. In the search box, type regedit, and then press ENTER.
4.Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters.
5. Click Parameters.
6.On the Edit menu, point toNew, and then click DWORD (32-bit) Value.
7.In Name, type "LogDataCreated" and ensure that the value is set to 0.
8.Close Registry Editor.
Restart the MSMQ Service
To restart the MSMQ Service:
1.Open the Services snap-in. To open Services, click Startservices.msc, and then press ENTER.
2.Right-click Message Queuing, and then click Restart. You must restart all the dependent services, as well.
Verify :
Verify that the MSMQ Service is installed and running.
To perform this procedure, you must have membership in Administrators, or you must have been delegated the appropriate authority.
To verfiy that the MSMQ Service is installed and running:
1)Open the Services snap-in. To open Services, click Start. In the search box, type services.msc, and then press ENTER.
2)Locate the Message Queuing service, and then confirm that the value in the Status column is Started.
3.For further confirmation, run a test application that uses the Active Directory features that you require.
Reference LinksEvent ID 2064 from Source MSMQ

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