Event ID - 18219

Event Id18219
SourceMicrosoft-Windows-COMRuntime
DescriptionThe computer-wide limit settings do not grant %1 %2 permission for COM Server applications to the user %3\%4 SID (%5) from address %6. This security permission can be modified by using the Component Services snap-in.
Event InformationAccording to Microsoft :
Cause :
This event is logged when the computer-wide limit settings do not grant permission for COM Server applications to the user SID from address.
Resolution :
Check the server's security policy
Update the security policy settings on the server to allow the requested operation to complete. The text of the event message may provide details to help you configure the security policy. Use the Component Services administrative tool to update the server's security policy to allow the requested operation to complete.
To perform this procedure, you must have membership in Administrators, or you must have been delegated the appropriate authority.
To open Component Services and find the server's security properties:
1.Click Start, and then click Run.
2.Type wf.msc, and then click OK. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue
3.To locate your computer, click Component Services, click ComputersMy Computer.
4.Right-click My Computer, click Properties, and then click the COM Security tab.
5.Under Access Permissions, click Edit Limits to check and, if necessary, change the Access Permissions limits on applications that determine their own permissions.
Under Launch and Activation Permissions, click Edit Limits to check and, if necessary, change the absolute limit on component launch and activation permissions.
6.Use Edit Default for each item to adjust Access Permissions and Launch and Activation Permissions to allow the requested operation to complete.
Verify
You can verify that your security policy for this server is configured properly by running the Component Services administrative tool and ensuring that the required security properties are set.
To perform this procedure, you must have membership in Administrators, or you must have been delegated the appropriate authority.
To open Component Services and verify that the required security properties are set:
1.Click Start, and then click Run.
2.Type comexp.msc, and then click OK. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
3.To locate your computer, click Component Services, click Computers, and then click My Computer.
4.Right-click My Computer, and then click Properties.
5.Click the COM Security tab, and confirm that the Access Permissions and Launch and Activition Permissions properties are set properly.
Reference LinksEvent ID 18219 from Source Microsoft-Windows-COMRuntime

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