Event ID - 1280

Event Id1280
SourceBINLSVC
DescriptionThe Windows Deployment Services server was unable to obtain a file lock on boot.sdi. Please ensure that the file is not in use by some other process. Error Information: %1
Event Information According to Microsoft :

Cause :

This event is logged when the Windows Deployment Services server was unable to obtain a file lock on boot.sdi.

Resolution :

Ensure that WDSServer has the correct permissions

To resolve this issue, do the following in the specified order:
  • Ensure that the WDSServer service has the correct permissions for the RemoteInstall folder.
  • Ensure that the server can read configuration data from the local registry.
  • Reinitialize the server.
Ensure that the WDSServer service has the correct permissions for the RemoteInstall folder

Often this problem occurs when the WDSServer service could not lock the Boot.sdi file located at C:RemoteInstall\Boot. This means that WDSServer needs to open the file with read/write permissions and limit others to read-only permissions, but it was unable to do this. This indicates that either the WDSServer service may not have Full Control file permissions or the file may be in use. To fix this problem, make sure that the WDSServer service has the necessary permissions for the RemoteInstall folder.

To perform this procedure, you must either be a member of the local Administrators group or have been delegated the appropriate authority.

To ensure permissions:
  1. Right-click the RemoteInstall folder (by default, this folder is located on drive C).
  2. On the Security tab, make sure that WDSServer is set to Full control .
If this does not fix the issue, use the procedure in the following section to ensure that the server can read the configuration data in the registry.

Ensure that the server can read configuration data from the local registry

The registry data may be missing or corrupt, or the computer may not have sufficient permissions to read the data.

Caution : Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.

To perform these procedures, you must either be a member of the local Administrators group or have been delegated the appropriate authority.

To ensure registry data and permissions:
  1. Open Registry Editor. (Click Start , type regedit in the Start Search box, and then press ENTER).
  2. Ensure that the following registry key exists: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\ .
  3. If this registry key exists, make sure that the SYSTEM account used by BINLSVC has permission to read from the registry. To do this, right-click the WDSServer node, click Permissions , click SYSTEM , and then make sure that Full Control is selected.
  4. If the specified registry key is missing or corrupt, you will need to use the procedure in the following section to reinitialize the server.
Reinitialize the server

To reinitialize the server:
  1. Open the Command Prompt window.
  2. At the command prompt, run wdsutil /uninitialize-server .
  3. At the command prompt, run wdsutil /initialize-server /reminst:(path) , where is the path where you would like the RemoteInstall folder to be located.
Verify :

To perform this procedure, you must either be a member of the local Administrators group or have been delegated the appropriate authority.

To verify that the BCD file has been generated correctly and is accessible:
  1. Locate the following file on the Windows Deployment Service server: RemoteInstall\Tmp\(arch).{(GUID)}.bcd, where is x86, x64, ia64, or x86x64 and is 32 characters. Note : By default, the RemoteInstall folder is on drive C.
  2. In the Command Prompt window, run the following command for the file you located in step 1: bcdedit.exe /enum /all /store: (Drive):\RemoteInstall\Boot\(arch)\default.bcd. The output should contain the contents of the BCD file.
  3. Verify that the output contains entries for each of your boot images.
Reference LinksEvent ID 1280 from Source BINLSVC

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