Event ID - 1115

Event Id1115
SourceMicrosoft-Windows-TerminalServices-Printers
DescriptionUnexpected internal error in TS RDP device redirection. Contact technical support.
Event InformationAccording to Microsoft :
Cause :
This event is logged when unexpected internal error in TS RDP device redirection.
Resolution :
Start the Print Spooler service or reinstall the printer driver
To resolve this issue, ensure that the Print Spooler service is running on both the client computer and the terminal server. If restarting the Print Spooler service does not resolve the issue, the printui.dll drive file on the terminal server might be corrupted. To resolve this issue, reinstall the printer driver on the terminal server.
To perform these tasks, refer to the following sections.
Start the Print Spooler service
To perform this procedure, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
To start the service:
  1. Open the Services snap-in. To open the Services snap-in, click Start, type services.msc, and then click OK.
  2. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  3. In the Services pane, right-click Print Spooler, and then click Properties.
  4. On the General tab, ensure that Startup type is set to Automatic. If it is not, click Automatic, and then click Apply.
  5. Under Service status, click Start.
  6. Click OK to close the Print Spooler Properties dialog box.
  7. Confirm that the Status column for the Print Spooler service displays Started.
Reinstall the printer driver on the terminal server
If the printer driver installed on the client computer is an OEM driver, and a driver is available from the printer's manufacturer, replace the OEM driver with the driver that is available from the printer manufacturer. If you are installing a third-party driver, make sure that the driver is a Windows Hardware Quality Labs (WHQL) signed driver.
Important : After you install the printer driver, terminal server clients must log off and then log on to the terminal server before the printer driver change takes effect.
To install the printer driver, use either of the following methods.
To perform these procedures, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
Method one
Run the printer's Setup program to install the printer driver .inf file on the terminal server.
Method two
To install the driver by using the Add Printer Driver Wizard:
  1. On the terminal server, click Start, click Run, type control printers, and then click OK.
  2. On the File menu, click Server Properties.
    Note : If the File menu is not visible, right-click an empty area of the Printers dialog box, and then click Server Properties.
  3. Click the Drivers tab.
  4. Click Add, and then follow the instructions in the Add Printer Driver Wizard to install the printer driver .inf file.
Verify :
To verify that printer redirection is working properly, establish a remote session with the terminal server and check that the redirected printer is available and is functioning as expected.
Reference LinksEvent ID 1115 from Source Microsoft-Windows-TerminalServices-Printers

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