Event ID - 10021

Event Id10021
SourceMicrosoft-Windows-DHCP-Server
DescriptionDHCPv6 service failed to initialize the database. The following error occurred: %1.
Event InformationAccording to Microsoft :
Cause :
This event is logged when DHCPv6 service failed to initialize the database.
Resolution :
Repair database and restore from a known good backup
If the DHCP server database becomes corrupted or is lost, recovery is possible by replacing the server database file (Dhcp.mdb), located in the %SystemRoot%\System32\Dhcp folder, with a backup copy of the same file.
If DHCP Manager was used previously to perform a backup, you can obtain the backup copy of the server database file located in the %SystemRoot%\System32\Dhcp\Backup folder. You can also restore the Dhcp.mdb file from a tape backup or other backup media.
To perform these procedures, you must be a member of the Administrators group, or you must have been delegated the appropriate authority.
To restore a backup copy of the DHCP database:
1.Click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as Administrator.
2.Type net stop dhcpserver, and then press ENTER.
3.Type md c:\olddhcp, and then press ENTER.
4.Type move %SystemRoot%\system32\DHCP\*.* c:\olddhcp, and then press ENTER.
5.Type del %SystemRoot%\system32\DHCP\Dhcp.md, and then press ENTER.
6.Type copy%SystemRoot%\system32\dhcp\backup\jet\new\dhcp.mdb%SystemRoot%\system32\dhcp\dhcp.mdb, and then press ENTER.
7.Type net start dhcpserver, and then press ENTER.
Verify :
To verify that the DHCPv6 service is running:
1.At the DHCPv6 server computer, click Start, click Run, and then type cmd.
2.At the command prompt, type sc queryex dhcp.
3.The DHCPv6 Server service state should be displayed as RUNNING.
Reference LinksEvent ID 10021 from Microsoft-Windows-DHCP-Server

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.