Event ID - 8647

Event Id8647
SourceMSSQLServer
DescriptionScan on sysindexes for database ID %d, object ID %ld, returned a duplicate index ID %d. Run DBCC CHECKTABLE on sysindexes.
Event InformationAccording to Microsoft

Cause:
The sysindexes table in the specified database has a data integrity problem. Data integrity problems are often a side effect of hardware problems. This message is often seen in conjunction with other data integrity messages.
Resolution:
HARDWARE FAILURE
Run hardware diagnostics and correct any problems. Also examine the Microsoft Windows NT system and application logs and the SQL Server error log to see if the error occurred as the result of hardware failure. Fix any hardware-related problems.
If you have persistent data inconsistency problems, try to swap out different hardware components to isolate the problem. Check that your system does not have write caching enabled on the disk controller. If you suspect this to be the problem, contact your hardware vendor.
Finally, you might find it beneficial to switch to a completely new hardware system, including reformatting the disk drives and reinstalling the operating system.
RESTORE FROM BACKUP
If the problem is not hardware related and a known clean backup is available, restore the database from the backup.
DBCC CHECKDB
If no clean backup is available, execute DBCC CHECKDB without a repair clause to determine the extent of the corruption. Since DBCC cannot fix system table errors you will not be able to use the repair clause to fix this particular error.
CAUTION:If you are unsure what effect DBCC CHECKDB with a repair clause has on your data, contact your primary support provider before executing this statement.
If running DBCC CHECKDB with one of the repair clauses does not correct the problem, contact your primary support provider.
Reference LinksEvent Id:8647 of Source Id:MSSQLServer

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.