Event ID - 8231

Event Id8231
SourceMicrosoft-Windows-IDMU-ServerForNIS
DescriptionLDAP error: %1.
Event InformationAccording to Microsoft :
Cause
This event is logged when LDAP error occurred.
Resolution
Check LDAP status
Server for NIS has closed because a Lightweight Directory Access Protocol (LDAP) error has occurred. Server for NIS was unable to communicate with the LDAP server or the LDAP server returned an unexpected failure response.
To resolve this problem:
1.Open Event Viewer and read the associated error message, which describes the cause of this error. A possible cause of this error is that the server on which Server for NIS is running is no longer an Active Directory® Domain Services domain controller. Server for NIS can only run on a domain controller.
2.Verify that the LDAP service is running on the host computer by doing the following:
a.Open the Services MMC snap-in (Services.msc) by clicking Start, pointing to Administrative Tools, and then clicking Services.
b.Verify that the Active Directory Domain Services domain controller service is running.
If the domain controller service does not exist, the computer is probably not a domain controller. Server for NIS can run only on an Active Directory Domain Services domain controller. To promote the computer to a domain controller, see the Active Directory Domain Services Help. Run the dcpromo utility and view the Help available with the dcpromo wizard.
c.If the service is not running, double-click the service in the results pane.
d.On the General tab of the Properties dialog box, set Startup type to Automatic.
e.Click OK.
Verify
Open the Services MMC and verify that Server for NIS is operational. If the Server for NIS service properties show that the service is not running, errors are preventing Server for NIS from operating normally.
To verify that Server for NIS is running
1.Click Start, point to Administrative Tools, and then click Services.
2.In the Results pane of the Services MMC, double-click Server for NIS.
3.In the Service status area of the Server for NIS Properties dialog box, verify that the Server for NIS service shows as Started.
Use the ypcat command on a client computer in the domain on which the error was generated to verify that the Server for NIS service is available.
To use the ypcat command to verify Server for NIS service availability:
1.On a client computer in the domain on which the error was generated, open a Windows Command Prompt with elevated privileges. To do this, right click Command Prompt on the Start menu, and then click Run as administrator.
2.Type the following command, and then press Enter: ypcat -hNISServer-dDomain Mapname. NISServer represents the name of the server on which you want to verify that the Server for NIS Service is available. Domain represents the domain name on which you want to verify that the Server for NIS service is available. Mapname represents the name or nickname of a specific NIS map that the server on which you want to verify Server for NIS availability is expected to update.
3.If you are prompted to provide the domain administrator account name and password, type the account name and password, and then press Enter.
4.The ypcat Windows command-line utility prints the values of all keys from the NIS database specified by Mapname, which can be a map name or a map nickname. If the ypcat utility returns a list of key values for the maps you specified, the Server for NIS service is available.
Reference LinksEvent ID 8231 from Microsoft-Windows-IDMU-ServerForNIS

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