Event ID - 78

Event Id78
SourceMicrosoft-Windows-PrintBRM
DescriptionPrintbrm.exe (the Printer Migration Wizard or the command-line tool) could not open registry key %1. Error code %2. This can occur if an important Windows resource (such as the registry) is unavailable, if the Component Object Model (COM) cannot be initialized, or if Printbrn.exe cannot allocate memory. Examine the Windows error returned by this event to determine the cause.
Event Information According to Microsoft :

Cause :

This event is logged when Printbrm.exe (the Printer Migration Wizard or the command-line tool) could not open registry key.

Resolution :

Ensure that the local registry is accessible, and optionally restart the server

Make sure that the local registry is accessible, and then restart the server, if necessary. To do this, use the following procedure:
  1. Open the Command Prompt window, and then type the following commands (in this order) at the command prompt: wmicregistry get
  2. Confirm that the registry get command reports OK in the Status column.
    If the status listed is not OK and you cannot access the registry by using the regedit command, restart the server. If you cannot do this locally, open the Command Prompt window by using a user account with Server Operator permissions for the remote server, and then type the following command to restart the server remotely (where is the Universal Naming Convention (UNC) path of the server you want to restart):
    shutdown /m \\ /r /t 0
  3. Retry importing or exporting printers.
Verify :

To verify that the Print Migration snap-in can access the registry and import or export printers properly, use one of the following two procedures.

To export printers using the Print Management snap-in, open Print Management and then perform the following steps:
  1. In the Print Management tree, right-click the name of the computer that contains the printer queues that you want to export, and then click Export printers to a file . This starts the Printer Migration Wizard, which you can use to export printers.
  2. Verify that the Printer Migration Wizard reports the following outcome: "The operation completed with no errors."
To export printers by using command-line commands, perform the following steps:
  1. Open the Command Prompt window.
  2. At the command prompt, type the following command: CD %WINDIR%\System32\Spool\Tools
  3. Type the following command, where is the name of the server from which you want to export printers and is the name of the printer settings file: Printbrm -s \\ -b f .printerExport
  4. Confirm that the output of the command states the following: "Successfully finished operation."
Reference LinksEvent ID 78 from Source Microsoft-Windows-PrintBRM

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