Event ID - 77

Event Id77
SourceMicrosoft-Windows-PrintBRM
DescriptionPrintbrm.exe (the Printer Migration Wizard or the command-line tool) cannot apply new settings for printer queue %1 because port %2 that is saved in the cabinet (.cab) file does not exist on the destination server. This can occur if Printbrm.exe failed to migrate the port. Manually install the appropriate port, and then specify the appropriate printer settings or retry importing the print queue.
Event Information According to Microsoft :

Cause :

This event is logged when Printbrm.exe (the Printer Migration Wizard or the command-line tool) cannot apply new settings for printer queue.

Resolution :

Install a printer port and restore the print queue settings

To install a printer port manually and set the printer settings:
  1. Open the Administrative Tools folder, and then double-click Print Management .
  2. Click Print Servers , click the print server you want to use, click Printers , right-click the printer for which the printer port was not imported, and then click Properties .
  3. Click the Ports tab, click Add Port , select the appropriate type of printer port, click New Port , and then follow the instructions on the screen.
  4. After installing the printer port, use the Properties dialog box to specify the appropriate printer settings.
Verify :

To confirm that print queues and all settings were successfully imported, perform the following tasks:
  • Confirm that all of the print queues that you exported from the source print server are listed in the Printers folder in Control Panel on the destination server to which you imported the print queues.
    If you have a large number of printers to compare, export a list of printers on the server from which you exported the print queues. Then export a list of printers from the server on which you imported the files, and then compare the results in Microsoft Excel or another spreadsheet program. To export a list of printers from a server, use the following procedure:

    1. On a computer running Windows Vista Business, Windows Vista Enterprise, Windows Vista Ultimate, or Windows Server 2008, open the Print Management snap-in from the Administrative Tools folder.
    2. In the Print Management tree, click the name of the computer that contains the printer queues that you exported (if available), right-click Printers , and then click Export List .
    3. Specify a file name for the list of printers, and then click Save .

  • Test printing to each printer. All documents should print properly.
  • Confirm that each printer is shared and accessible from other computers on the network and has the appropriate printer preferences for your environment.
  • Confirm that the printer was successfully published to Active Directory Domain Services (AD DS), if appropriate.
To do this, look for Print Spooler Event 36 or Print Spooler Event 40 in Event Viewer (if the print server logs spooler information events), or use the following procedure to search AD DS for the printer:
  1. On a computer in the same domain as the print server, open the Printers folder in Control Panel and then click Add a printer . The Add Printer Wizard appears.
  2. Select A printer that is not attached to my computer (a network printer) , and then click Next .
  3. Click The printer I am looking for is not on this list .
  4. Select Find a printer in Active Directory, based on location or feature , click Next , and then use the Find Printers dialog box to search AD DS for the printer.
Reference LinksEvent ID 77 from Source Microsoft-Windows-PrintBRM

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.