Event ID - 77

Event Id77
SourceAltiris Recovery Solution
DescriptionThe client job for the protected computer COMPUTERNAME with database ID=43 was canceled because it hasn't been updated for 1800 seconds and is probably stalled.
Event InformationAccording to Altiris:
Cause:

All snapshots are stalling due to threads synchronization problems in DSRawData.dll module which are more likely to appear on multi-processor servers

Resolution:
This fix will resolve the following issues related to Recovery Solution:
Concurrent snapshots are hanging and stalling with Event ID 77 errors logged in the Application Event of the Recovery Solution Server.
AeXVault crashes during multiple snapshots.
AeXVault crashes during startup.
Altiris Recovery Solution Server Service hanging at startup and stop.
Exception during the SSM job for the dataset with approximately 10,000 modified files.
GetFilterList errors affecting the Recovery Solution Server performance.
Memory leaks during Server Space Management Job.
Recovery Solution Server ran out of Database Connection.
The attached hotfix should be applied on the Recovery Solution Server which will stop all the snapshots from stalling and hanging.


Notes for installing the hotfix:

The hotfix attached to this article specifically applies to Recovery Solution 6.1.1621. To install this hotfix, click on this link: Altiris_RS_6_1_SP2_KB20717.exe
This will replace all the old libraries and the AeXVault.exe with the new libraries and new AeXVault.exe on the Recovery Solution Server and restart the Recovery Solution Server Service automatically
The hotfix will not be seen in Control Panel > Add or Remove Programs on Windows 2003 servers without SP1. It is not possible to uninstall the hotfix from Add or Remove Programs without SP1. To uninstall the hotfix, the attached Batch File should be used instead of Add or Remove Programs while the Recovery Solution Server Services are in the stop mode.
Custom registry changes made for Recovery Solution on Windows 2003 SP1 will be dropped.
Custom settings for the Recovery Solution Server Service will be dropped and will be restore to the default settings.
Before un-installing this Hotfix, Altiris Recovery Solution Server Service should be stopped. The batch file for uninstall will restore the old libraries and AeXVault.exe.
For Recovery Solution Servers which are not local to Notification Server, the hotfix should be applied locally to the Recovery Solution Server.
The Hotfix installation will not touch any libraries except included in the Hotfix. So all the unofficial hotfixes which were installed on the Recovery Solution Server will remain installed and there will be no need to re-apply them.
While the Hotfix uninstallation using the Batch File will replace the libraries to the original (since repair is performed as part of the hotfix uninstallation) and there will be a need to re-apply all the unofficial hotfixes after this.
Reference Linksevent id: 77 and source:Altiris Recovery Solution

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