Event ID - 654

Event Id654
SourceMicrosoft-Windows-ADFS
DescriptionThe Federation Service encountered an error while loading the trust policy. An account partner has no identity claim transformation. Account partner: %1 If this error occurs during startup of the Federation Service, the Federation Service will not be able to start and all requests to the Federation Service will fail until the configuration is corrected. If this error occurs while the Federation Service is running, the Federation Service will continue to use the last policy that was loaded successfully. User Action This error should occur only if the trust policy file has been modified without use of the AD FS administrative tools. Configure an identity claim transformation for this partner.
Event Information According to Microsoft :

Cause :

This event is logged when the Federation Service encountered an error while loading the trust policy.

Resolution :

Configure an identity claim mapping for at least one of the claim types

This error occurs only if the trust policy (trustpolicy.xml) file has been modified without the use of the Active Directory Federation Services snap-in and the modification causes another relying parameter to fall outside the scope of acceptable values. In this case, the manual change that was made to the trustpolicy.xml file removed or disabled all identity claim mappings that were associated with the account or resource partner.

To correct this problem, enable at least one identity claim mapping for the partner claim types: user principal name (UPN), e-mail, or common name.

To perform this procedure, you must be a member of the local Administrators group, or you must have been delegated the appropriate authority.

To manually enable a claim mapping in the trustpolicy.xml file:
  1. In Notepad or another text editor, open the trustpolicy.xml file, which by default is in %systemdrive%\windows\systemdata\adfs.
  2. In the UpnSuffixValidation section, change the value of the Disabled element from true to false .
  3. Save and close Notepad.
Verify :

Verify that you can access the Active Directory Federation Services (AD FS)-enabled application from a client browser and that the resource can be accessed.
Reference LinksEvent ID 654 from Source Microsoft-Windows-ADFS

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.