Event ID - 624

Event Id624
SourceMicrosoft-Windows-TerminalServices-Gateway
DescriptionThe TS Gateway server "%1" is not a member of a domain and therefore cannot be added to the TS Gateway server farm. To add this TS Gateway server to the farm, you must first add the server to a domain.
Event InformationAccording to Microsoft :
Cause :
This event is logged when the TS Gateway server is not a member of a domain and therefore cannot be added to the TS Gateway server farm.
Resolution :
Add the TS Gateway server to a domain
To resolve this issue, add the TS Gateway server to a domain.
To perform this procedure, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
To add the TS Gateway server to a domain:
  1. Click Start, right-click Computer, and then click Properties.
  2. Under Computer name, domain, and workgroup settings, click Change settings.
  3. On the Computer Name tab, click Change.
  4. In the Computer Name/Domain Changes dialog box, under Member of, click Domain, type the name of the domain to which you want to add the TS Gateway server, and then click OK.
  5. When prompted, in the Computer Name/Domain Changes dialog box, enter the appropriate credentials.
  6. In the Computer Name/Domain Changes dialog box, a welcome message appears to confirm that the computer was successfully added to the domain. Click OK.
  7. The Computer Name/Domain Changes dialog box will appear again, stating that the computer must be restarted for the changes to be applied. Click OK.
  8. Click Close to close the System Properties dialog box.
  9. A message will appear prompting you to choose whether to restart the computer immediately or later. Click Restart now to restart the computer immediately. If you click Restart later, the computer will not be added to the domain until you restart the computer.
Verify :
To verify that the TS Gateway server is available for client connections, examine Event Viewer logs and search for the following event messages. These event messages indicate that the Terminal Services Gateway service is running, and that clients are successfully connecting to internal network resources through the TS Gateway server.
To perform this procedure, you do not need to have membership in the local Administrators group. Therefore, as a security best practice, consider performing this task as a user without administrative credentials.
To verify that the TS Gateway server is available for client connections:
  1. On the TS Gateway server, click Start, point to Administrative Tools, and then click Event Viewer.
  2. In the Event Viewer console tree, navigate to Application and Services Logs\Microsoft\Windows\TerminalServices-Gateway, and then search for the following events:
    • Event ID 101, Source TerminalServices-Gateway: This event indicates that the Terminal Services Gateway service is running.
    • Event ID 200, Source TerminalServices-Gateway: This event indicates that the client connected to the TS Gateway server.
    • Event ID 302, Source TerminalServices-Gateway: This event indicates that the client connected to an internal network resource through the TS Gateway server.
Reference LinksEvent ID 624 from Source Microsoft-Windows-TerminalServices-Gateway

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