Event ID - 6162

Event Id6162
SourceMicrosoft-Windows-PrintSpooler
DescriptionThe spooler has detected that a component has an unusually large number of open Graphical Device Interface (GDI) objects. As a result, some enhanced metafile (EMF) print jobs might not print until the spooler is restarted.
Event Information According to Microsoft :

Cause :

This event is logged when the spooler has detected that a component has an unusually large number of open Graphical Device Interface (GDI) objects.

Resolution :

Restart the Print Spooler service

Possible resolutions include:
  • If you are using Microsoft Office 2003 or Microsoft Office 2003 Service Pack 1 on the client computer, install Microsoft Office 2003 Service Pack 2 or newer, or install the hotfix described in Microsoft Knowledge Base article 896604.
  • If you are using Windows Server 2003 or Windows 2000 Server on the client computer, you could be experiencing a Graphical Device Interface (GDI) handle leak caused by Windows removing a window before removing a GDI brush object. To resolve this issue, see Microsoft Knowledge Base Article 826518.
  • Restart the print spooler by using the following procedure.
    Warning : Restarting the Print Spooler service causes all print jobs to be restarted. After restarting the Print Spooler service, you might need to reset some printers or turn them off and then turn them back on. On an active print server, perform this procedure outside of normal business hours or during scheduled maintenance time, if possible. Before performing this procedure, take all printers offline and wait for all print jobs to be completed, or pause all printers and wait for all Active print jobs to be completed.

    1. In the Administrative Tools folder, open the Services snap-in.
    2. Locate the Print Spooler service in the list of services, and then confirm that its status is Started . If its status is not Started , select the service and then click Start on the Action menu.
      Note : You can also do this from an elevated Command Prompt window by typing the following command: net stop spooler && net start spooler

    In some instances, you might receive Error 1068 – "The dependency service or group failed to start" – when attempting to start the print spooler. This can happen if the Print Spooler service relies on other services that are not running. To resolve this issue, use the following procedure:

    1. In the Services snap-in, right-click Print Spooler and then click Properties .
    2. Click the Dependencies tab. The first box lists all of the system services that must be running for the Print Spooler to start. These are the dependencies.
    3. Make a note of each service, click OK , and then start each service that the Print Spooler service depends on, if the service is not already started. If a particular service was not already started, right-click it, click Properties , and then confirm that the Startup type is Automatic .
Verify :

Perform the following tasks to verify that you resolved the problem:
  • Print the document again.
  • If the print server logs spooler information events, look for Print Spooler Event 10 after printing, and then examine the document to confirm that it printed correctly.
Reference LinksEvent ID 6162 from Source Microsoft-Windows-PrintSpooler

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.