Event ID - 52

Event Id52
SourceTermService
DescriptionObject Name not found.
Event InformationThe client computer may receive the following error messages if you try to establish a Terminal Services connection: 
Terminal Services Client Disconnected
The client could not connect to the Terminal server. The server may be too busy. Please try connecting later. 
-or- 
Terminal Services Client Disconnected
The Terminal server has ended the connection
CAUSE :
This problem may occur if the RDP-tcp listener was not initialized or if the Terminal device driver is not started. You may have to verify that the license key is correct. 
RESOLUTION :
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this problem, first determine the cause of the problem by using the following list, and then follow the applicable steps: 
The RDP-tcp connection may have to be reset. To reset the RDP-tcp connection in the Terminal Services Configuration management console, right-click the connection, and then click Disable. Confirm the changes when you are prompted to do so. Repeat the process, and then click Enable.
The RDP-tcp connection may be corrupted. Re-create the RDP-tcp connection in the Terminal Services Configuration management console. To re-create the connection, delete the connection, and then re-create it.
An evaluation license may have been used to configure Terminal Services Licensing. Verify that a retail license has been
Reference Links Event ID 52 When You Start Terminal Services

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.