Event ID - 51

Event Id51
SourceMicrosoft-Windows-PrintSpooler
DescriptionPrint queue %1 could not be deleted (pruned) from the Active Directory directory service. Error: %2. The spooler will periodically try to remove the entry until it is successful. Continued failures may indicate an Active Directory problem, a basic network problem, or a communication problem between the domain controller and the print server.
Event Information According to Microsoft :

Cause :

This event is logged when print queue could not be deleted (pruned) from the Active Directory directory service.

Resolution :

Allow the spooler to retry pruning the printer

The spooler will periodically try to remove the entry until it succeeds in doing so. Continued failures may indicate an Active Directory Domain Services (AD DS) problem, a basic network problem, or a communication problem between the domain controller and the print server.

No user action is required. If the spooler continues to fail when trying to remove the print spooler from AD DS and it is important that the printer is removed from AD DS, try the following actions to resolve the issue:
  • Fix DNS server problems.
  • Fix AD DS problems.
Fix DNS server problems

To resolve DNS server problems:
  1. Restart the DNS Server service on the DNS server. To do this, open the Services snap-in from the Administrative Tools folder, click the DNS Server service, and then click the Restart Service toolbar button.
  2. Allow the print spooler to prune the printer automatically, or manually remove the printer from AD DS by using the following procedure:
    a.Open either the Print Management snap-in .
    b.In the Print Management tree, click Printers under the appropriate print server.
    c.In the Results pane, select the printer or printers that you want to list or remove, right-click one of the printers, and then click Remove from Directory .
    Note You can also perform this procedure from the Printers folder in Control Panel. To do so, right-click the appropriate printer, click Properties , click the Sharing tab, and then select or clear the List in the directory checkbox.
For more information about troubleshooting DNS server problems, see the following Microsoft Web sites:
  • Troubleshooting DNS
  • Troubleshooting Domain Name System
  • Troubleshooting Windows Server 2008
Fix AD DS problems

To resolve Active Directory Domain Services (AD DS) problems, do the following:
  • Confirm that there is a domain controller available in the same domain as the print server.
  • Resolve any DNS problems that are related to AD DS. For more information, see Active Directory Operations Overview: Troubleshooting Active Directory-Related DNS Problems.
  • Confirm that sites are set up properly in AD DS and that printer location tracking is properly enabled. For more information, see Troubleshooting common printing problems.
  • If user accounts are in a different domain from the print server computer account, and any of the domains use the Windows 2000 mixed-domain functional level, consider switching the domain functional levels.
  • Allow the print spooler to prune the printer automatically, or manually remove the printer from AD DS by using the following procedure:

    1. Open the Administrative Tools folder, and then double-click Print Managemen t.
    2. In the Print Management tree, click Printers under the appropriate print server.
    3. In the Results pane, right-click the printer you want to list or remove, and then click Remove from Directory .
      Note You can also perform this procedure from the Printers folder in Control Panel. To do so, right-click the appropriate printer, click Properties , click the Sharing tab, and then select or clear the List in the directory checkbox.
If you continue to have AD DS problems, you can try the following actions to further diagnose the problem:
  • Using an account that is a member of the Enterprise Admins group, open the Command Prompt window, and then type dcdiag /e to diagnose the health of the entire AD DS forest.
  • In Event Viewer, connect to one of the affected domain controllers, examine the Directory Service log for possible Error or Warning events, and then click the Event Log Online Help link for each Error or Warning event. This opens a Web browser with additional troubleshooting information pertaining to the specific event.
Verify :

To verify that the printer was successfully published or removed from AD DS, do the following:
  • If the print server logs spooler information events, open Event Viewer and look for Print Spooler Event 36 (when publishing a printer), Print Spooler Event 38 (when removing a printer from AD DS), or Print Spooler Event 40 (when updating a printer).
  • Search AD DS for the printer by using the following procedure:

    1. Open the Printers folder on a computer in the same domain as the print server, and then click Add a printer . The Add Printer Wizard appears.
    2. Select A printer that is not attached to my computer (a network printer) , and then click Next .
    3. Click The printer I am looking for is not on this list .
    4. Select Find a printer in Active Directory, based on location or feature , click Next , and then use the Find Printers dialog box to search AD DS for the printer.
Reference LinksEvent ID 51 from Source Microsoft-Windows-PrintSpooler

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