Event ID - 5149

Event Id5149
SourceWindows SharePoint Services 3
DescriptionTracing Service initialization failed. The trace log may be unavailable. Error %1: %2.
Event InformationAccording to Microsoft :
Cause :
This event is logged when Tracing Service initialization failed.
Diagnose:
Windows SharePoint Services 3.0 could not create, or write to, the trace log. This trace log contains information that is useful in troubleshooting issues.
This error might be caused by one of the following conditions:
a)The account that Windows SharePoint Services 3.0 is using does not have sufficient rights to the trace log.
b)The hard disk or partition does not have enough room.
To find the location of the log file folder
1.In Central Administration, on the left navigation pane, clickOperations.
2. In theLogging and Reporting section, clickDiagnostic Logging.
3. On the Diagnostic Logging page, in theTrace Log section, the path to the log file is displayed in thePath box.
The account that Windows SharePoint Services 3.0 is using does not have sufficient rights to the trace log
To check the permissions assigned to the log file folder
1.If you do not know the location of the folder, see the "To find the location of the log file folder" procedure. By default, the location is "Program Files\Common Files\Microsoft Shared\web extensions\12\LOGS" but the location can be changed in Central Administration.
2.Navigate to the folder, right-click the folder, and then click Properties.
3.On the Security tab, the WSS_ADMIN_WPG Windows group should have Full Control and the WSS_WPG Windows group should have Read & Execute, List Folder Contents, and Read permissions or higher on the folder. If they do not, assign these permissions by using the procedure in the "Assign sufficient permissions" section.
The hard disk or partition does not have sufficient room
To check the space on the disk or partition1.If you do not know the location of the folder, see the "To find the location of the log file folder" procedure. By default, the location is "Program Files\Common Files\Microsoft Shared\web extensions\12\LOGS" but the location can be changed in Central Administration.
2. Navigate to the disk or partition, right-click it, and then clickProperties.
3. On the General tab, check the free space. The drive or partition should have at least 500 MB for the log files. Note: the space required for the log files depends upon the diagnostic logging settings.
Resolution :
Assign sufficient permissions to the trace log
Windows SharePoint Services 3.0 could not write to the trace log because the account that Windows SharePoint Services 3.0 is using does not have sufficient permissions to the trace log or its parent directory. This trace log contains information that is useful in troubleshooting issues.
Ensure that the WSS_ADMIN_WPG Windows group has Full Control and the WSS_WPG Windows group has Read & Execute, List Folder Contents, and Read permissions or higher on the folder containing the trace log. To perform this procedure, you must be a member of the Administrators group on the local computer.
Free up disk space or relocate the trace log
Windows SharePoint Services 3.0 could not write to the trace log. This trace log contains information that is useful in troubleshooting issues.
You can free up space on the drive containing the trace log by removing unneeded files. To perform this procedure, you must be a member of the Administrators group on the local computer.
You can change the location of the trace log to a partition that has more drive space.
To change the location of the trace log file
1.In Central Administration, on the left navigation pane, click Operations.
2.On the Operations page, in theLogging and Reporting section, clickDiagnostic logging.
3.On the Diagnostic Logging page, in theTrace Log section, type the new location for the trace log file in thePath box.
4.Click OK.
Verify :
Ensure that Windows SharePoint Services 3.0 can create, and write to, the trace log file.
To check if Windows SharePoint Services 3.0 can create, and write to, the trace log file
1.In the SharePoint Central Administration Web site, on the left navigation pane, click Operations.
2.On the Operations page, in theLogging and Reporting section, clickDiagnostic logging.3.On the Diagnostic Logging page, in the Trace Log section, copy the path to the trace log file from the Path box.
4.In Windows Explorer, navigate to the trace log file by using the copied path and open the file in Notepad, or another text editor.
Reference LinksEvent ID 5149 from Source Windows SharePoint Services 3

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.