Event Information | According to Microsoft :
Cause :
This event is logged when an error occurred while trying to initialize provider.
Resolution :
Fix other errors
Normal operation of the Windows Deployment Services server service (WDSServer) depends on various provider components. If one of these providers fails, WDSServer will also be affected. Because this failed provider is marked as noncritical, it is possible that you are not using the provider in your solution. If you are not using the provider, you can disregard this error.
To resolve this issue, do both of the following: - Check the server requirements.
- Find the root cause.
Check the server requirements
To resolve this issue, first ensure the following: - Your server is running Windows Server 2008 in a domain that contains working DHCP and DNS servers.
- You have an NTFS file system on the server (this is a requirement for storing images). To check this, click Start , click Computer , right-click the drive name, click Properties , and then make sure that File system is set to NTFS .
If the server meets both of these requirements, use the information in the following section to find the root cause of the error.
Find the root cause - If this event was caused by a non-Microsoft provider, contact the vendor for troubleshooting information.
- If you are using the default providers (for example, WDSPXE and BINLSVC), use the following procedure to find the root cause of this error.
To find the root cause of the error: - Open Event Viewer (Click Start , type Event Viewer in the Start Search box, and then press ENTER .)
- In the left pane, expand Custom Views , expand Server Roles , and then click Windows Deployment Services .
- Click the Date and Time column heading to sort the events based on date and time.
- Review the events that have a similar date and date as this event (WDSServer event 512).
- Click the related event, and then click Event Log Online Help at the bottom of the General tab.
- Follow the instructions to resolve the error (WDSServer event 512).
- After you have resolved the root error, restart the WDSServer service. (In the Command Prompt window, run net stop wdsserver and then run net start wdsserver .)
Any of the events in the following three lists may be the root cause of the error: - WDSPXE : 513, 768, 774, 770, 772, 776, 256, 257, 258, 259, 260, 261, 263, 265, 266, 268
- BINLSVC : 512, 513, 515, 516, 517, 518, 1800, 1794, 1809, 1795, 1797, 1799, 1281, 1283, 1287, 1302, 1303, 1304, 1284, 1285, 1286, 1295, 1296, 1297, 1299, 1300
- WDSIMGSR : 258
Verify :
To verify that the state of the WDSServer service is active: - Open Computer Management (click Start , click Administrative Tools , and then click Computer Management ).
- Expand Services and Applications , and then click Services .
- Verify that the status of Windows Deployment Services Server is Started .
Note : Alternatively, you can run sc control wdsserver 130 at a command prompt and verify that the state is equal to 4 . |