Event ID - 502

Event Id502
SourceMicrosoft-Windows-DNS-Server-Service
DescriptionThe DNS server has detected that for the primary zone %1 its has no zone file name stored in registry data. You can either update the zone file name or delete the zone and recreate it using the DNS console. To delete the applicable zone from the registry, locate its subkey under DNS server parameters in the registry. You can then recreate the zone using the DNS console.
Event InformationAccording to Microsoft :
Cause :
This event is logged when DNS server has detected that for the primary zone its has no zone file name stored in registry data.
Resolution :
Correct zone data
A registry value that contains information for a zone is corrupt or incorrect and must be corrected. You can use Server Manager to delete the zone and then recreate it.
To perform this procedure, you must have membership in Administrators, or you must have been delegated the appropriate authority.
To use Server Manager to recreate a zone:
1.On the DNS server, start Server Manager. To start Server Manager, click Start, click Administrative Tools, and then click Server Manager.
2.In the console tree, double-click Roles, double-click DNS Server, and then double-click DNS.
3.Expand the DNS server, and then expand the folder that contains the zone.
4.Right-click the zone, and then click Delete.
Note: If you cannot delete the zone using this method, you must use Registry Editor to delete the registry key for the zone.
5.Right-click the folder, and then click New Zone.
6.Follow the instructions in the wizard to recreate the zone.
To delete the zone key in the registry:
Caution: Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.
1.On the DNS server, click Start.
2.In Start Search, type regedit, and then press ENTER.
3.In the console tree, expand the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\DNS Server\Zones.
4.Right-click the key for the zone, and then click Delete.
Verify
To verify that the Domain Name System (DNS) configuration is correct, verify that all configuration settings are correct, check the event log for events that indicate continuing problems, and then verify that DNS client computers are able to resolve names properly.
To verify DNS configuration settings:
1.On the DNS server, start Server Manager. To start Server Manager, click Start, click Administrative Tools, and then click Server Manager.
2.In the console tree, double-click Roles, double-click DNS Server, and then double-click DNS.
3.Right-click the DNS server, and then click Properties.
4.Review the settings on each tab, and verify that they contain the intended values.
5.Expand the DNS server.
6.Expand a zone folder, right-click a zone, and then click Properties.
7.Review the settings on each tab, and verify that they contain the intended values.
8.Repeat steps 6 and 7 for each zone.
To verify that DNS client computers can resolve names properly:
1.On a DNS client computer, open a command prompt. To open a command prompt, click Start, click Run, type cmd, and then click OK.
2. At the command prompt, type pinghostname (where hostname is the DNS name of a computer with a known IP address), and then press ENTER.
If the client can resolve the name, the ping command responds with the following message:
Pinging hostname [ip_address]
Note: The name resolution is successful even if the ping command reports that the destination is unreachable.
If the client cannot resolve the name, the ping command responds with the following message:
Ping request could not find host hostname
Reference LinksEvent ID 502 from Microsoft-Windows-DNS-Server-Service

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