Event Information | According to Microsoft :
Cause :
This event is logged when the threading model of the component specified in the registry is inconsistent with the registration database.
Resolution :
Reinstall the COM+ Application
The event message indicates that there is a mismatch between the registry and the COM+ registration database. This problem can occur if a user or program edits the registry after a COM+ application is installed. To resolve this issue: - If you know the change that was made to the registry, revert the change.
- If you do not know the change that was made to the registry, uninstall and then reinstall the COM+ application.
To perform these procedures, you must have membership in Administrators , or you must have been delegated the appropriate authority.
To uninstall the COM+ application: - Identify the application to uninstall by looking in the details of the error message.
- Click Start , and then click Run .
- Type comexp.msc , and then click OK . If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue .
- To locate your application, click Component Services , click Computers , click My Computer , and then click COM+ Applications .
- Right-click the application name, and then click Shut down . Expand the application name if necessary, right-click the application, and then click Delete .
Or
If the component is a library application, make sure that all processes that are currently using this library application are shut down, and then click Delete .
Note : If Delete is not available, click Properties , click the Advanced tab, and then clear the Disable deletion check box. To reinstall the COM+ application: - Click Start , and then click Run .
- Type comexp.msc , and then click OK . If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue .
- Click Component Services , click Computers , click My Computer , and then click COM+ Applications .
- On the Action menu, click New .
- Follow the instructions in the COM+ Application Install Wizard.
Verify :
You can verify that your component is working properly by running the Component Services administrative tool and ensuring that the required properties for the component are set.
To perform the procedures, you must have membership in Administrators , or you must have been delegated the appropriate authority.
To open Component Services and verify that the component's required properties are set: - Click Start , and then click Run .
- Type comexp.msc , and then click OK . If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue .
- To locate your application, click Component Services , click Computers , click My Computer , and then click COM+ Applications .
- Right-click the component name, and then click Properties .
- In the component properties dialog box, click each tab to verify that the required properties are set.
In addition, you can verify that the COM+ operating system component is installed and working properly.
To verify that COM+ is working properly: - In the console tree of Component Services, click Services (Local) .
- Scroll through the list of service names to find the following services: COM+ Event System (optional), COM+ System Application, DCOM Server Process Launcher , and Remote Procedure Call (RPC) .
- Confirm that the status of each service is Started .
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