Event ID - 4437

Event Id4437
SourceMicrosoft-Windows-MSDTC
DescriptionThe account that the MS DTC service is running under is invalid. This can happen if the service account information has been changed using the Services snap-in in Microsoft Management Console (MMC). MS DTC service will continue to start. Please make sure that the MS DTC service account information is updated using the Component Services Explorer.
Event Information According to Microsoft :

Cause :

This event is logged when the account that the MS DTC service is running under is invalid.

Resolution :

Restore the default account

The default account for running the Micrsoft Distributed Transaction Coordinator service (MSDTC), known as the DTC Logon Account, may have been changed. The default account is NT AUTHORITY\NetworkService. Use the Component Services administrative tool to restore the default account name.

To perform this procedure, you must have membership in Administrators , or you must have been delegated the appropriate authority.

To open Component Services and restore the default DTC Logon Account:
  1. Click Start , and then click Run .
  2. Type comexp.msc , and then click OK . If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue .
  3. Click Component Services , click Computers , click My Computer , click Distributed Transaction Coordinator and then click Local DTC .
  4. Right-click the Local DTC , and then click Properties .
  5. In the Local DTC properties dialog box, click the Security tab. Under DTC Logon Account , in the Account box, type NT AUTHORITY\NetworkService . The password should be blank.
Verify :

Use Registry Editor on the server to verify that the Microsoft Distributed Transaction Coordinator service (MSDTC) registry settings are appropriate.

To perform this procedure, you must have membership in Administrators , or you must have been delegated the appropriate authority.

To open the Registry Editor on the server and verify MSDTC registry settings:
  1. Click Start , click Run , and then type regedit . If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue .
  2. Click HKEY_LOCAL_MACHINE , expand Software , expand Microsoft , and then expand MSDTC .
  3. Check whether the registry keys are appropriate. To check a registry key, in the details pane, right-click the provider information that you want to view, and then click Modify . You can close the dialog box without making changes.
Reference LinksEvent ID 4437 from Source Microsoft-Windows-MSDTC

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.