Event ID - 4183

Event Id4183
SourceMicrosoft-Windows-MSDTC
DescriptionMS DTC Transaction Manager start failed. QueryInterface on TransactionTrackerFactory returned error %1.%0
Event Information According to Microsoft :

Cause :

This event is logged when MS DTC Transaction Manager start failed.

Resolution :

Restore Msdtclog.dll, and restart MSDTC

The system indicates that there is a problem with the Msdtclog.dll file, which is located in the \windows\system32 folder. Check this folder to see if the Msdtclog.dll file is there. If the Msdtclog.dll file is present in the \windows\system32 folder, stop and then restart the Microsoft Distributed Transaction Coordinator service (MSDTC). If the file is not there, restore it from a backup (or other means) to this location, and then restart MSDTC.

To perform these procedures, you must have membership in Administrators , or you must have been delegated the appropriate authority.

To open Component Services and restart MSDTC:
  1. Click Start , and then click Run .
  2. Type comexp.msc , and then click OK . If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue .
  3. Click Services
  4. In the Services pane , right-click Distributed Transaction Coordinator , and then click Restart .
    The system stops and then restarts MSDTC.
To stop and then restart MSDTC if the Msdtclog.dll file is not present in the default location:
  1. Click Start , and then click Command Prompt .
  2. At the command prompt, type net stop msdtc , and then press ENTER.
  3. At the command prompt, type net start msdtc , and then press ENTER.
Verify :

Use the Component Services administrative tool to verify that the log file for the Microsoft Distributed Transaction Coordinator service (MSDTC) is created in the appropriate location.

To perform this procedure, you must have membership in Administrators , or you must have been delegated the appropriate authority.

To open Component Services and verify the location of the MSDTC log file:
  1. Click Start , and then click Run .
  2. Type comexp.msc , and then click OK . If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue .
  3. Click Component Services , click Computers , click My Computer , and then click Distributed Transaction Coordinator , and then click Local DTC .
  4. Right-click the Local DTC , and then click Properties .
  5. In the Local DTC properties dialog box, click the Logging tab. Under Log Information ,verify that the location of the log file is appropriate for the MSDTC.
Reference LinksEvent ID 4183 from Source Microsoft-Windows-MSDTC

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.