Event ID - 4124

Event Id4124
SourceMicrosoft-Windows-MSDTC
DescriptionUnable to decompress the MS DTC log file. Please ensure that there is sufficient available disk space on the MS DTC log device.%0
Event Information According to Microsoft :

Cause :

This event is logged when Unable to decompress the MS DTC log file.

Resolution :

Free disk space, or move the log file to another drive

There is not enough disk space for the log file for Microsoft Distributed Transaction Coordinator service (MSDTC) in its current location. Check the current location of the MSDTC log file, and then free disk space on that drive by deleting files, or move the log file to another drive with more disk space.

To perform these procedures, you must have membership in Administrators , or you must have been delegated the appropriate authority.

Check the location of the MSDTC log file:
  1. Click Start , and then click Run .
  2. Type comexp.msc , and then click OK . If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue .
  3. Click Component Services , click Computers , click My Computer , and then click Distributed Transaction Coordinator , and then click Local DTC .
  4. Right-click the Local DTC, and then click Properties .
  5. In the Local DTC properties dialog box, click the Logging tab. Under Log Information ,check the path in Location to identify the current drive and location of the log file. By default, the log file is located in the \windows\system32 folder.

    If you decide to move the log file to another drive, first stop MSDTC, move the log file, and then restart MSDTC.
Stop MSDTC

To stop MSDTC:
  1. Click Start , and then click Command Prompt .
  2. At the command prompt, type net stop msdtc , and then press ENTER.
Move the MSDTC log file to another drive

To open Component Services and move the MSDTC log file to another drive:
  1. Click Start , and then click Run .
  2. Type comexp.msc , and then click OK . If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue .
  3. Click Component Services , click Computers , click My Computer , and then click Distributed Transaction Coordinator , and then click Local DTC
  4. Right-click the Local DTC , and then click Properties .
  5. In the Local DTC properties dialog box, click the Logging tab. Under Log Information ,in Location , type a new drive letter and location for the log file.
Restart MSDTC

To restart MSDTC:
  1. Click Start , and then click Command Prompt .
  2. At the command prompt, type net stop msdtc , and then press ENTER.
Verify :

Use the Component Services administrative tool to verify that the log file for the Microsoft Distributed Transaction Coordinator service (MSDTC) is created in the appropriate location.

To perform this procedure, you must have membership in Administrators , or you must have been delegated the appropriate authority.

To open Component Services and verify the location of the MSDTC log file:
  1. Click Start , and then click Run .
  2. Type comexp.msc , and then click OK. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
    3.Click Component Services , click Computers , click My Computer , and then click Distributed Transaction Coordinator , and then click Local DTC
  3. Right-click the Local DTC , and then click Properties .
  4. In the Local DTC properties dialog box, click the Logging tab. Under Log Information ,verify that the location of the log file is appropriate for the MSDTC.
Reference LinksEvent ID 4124 from Source Microsoft-Windows-MSDTC

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.