Event ID - 4058

Event Id4058
SourceMSExchangeIMC
DescriptionThe Internet Mail Connector cannot start because the name resolver cannot be initialized. Check your network settings in the Control Panel to ensure that you have set a domain name in the DNS dialog box of the TCP/IP configuration.
Event InformationAccording to Microsoft:
CAUSE:
The Internet Mail Service is created by the SBS installation, but numerous settings required for it to run are not set by default. When the Internet Connection Wizard is run, the settings are complete and the Internet Mail Service should run successfully.
RESOLUTION:
If you are going to connect to the Internet, and will set up Internet connectivity using the Internet Connection Wizard, you can ignore these errors until you run the wizard.
To run the Internet Connection Wizard, open the Manage Server Console, click More Tasks, click Manage Internet Access, and then select Sign-up with an ISP. For more information on the Internet Connection Wizard, see the More Information section of this article.
However, if the Internet Mail Service is not needed, use the following steps:
1. Click Start, click Programs, click Microsoft Exchange, and then click Exchange Administrator.
2. In the left pane of Exchange Administrator, expand the Site Name container (it should be a green globe with the name of your company in bold, as entered during installation).
3. Below the site name, expand the Configuration container.
4. Below the Configuration container, select the Connections container.
5. There should be an object here named Internet Mail Service (SBSSERVERNAME). Select it, go to the Edit menu, and then click Delete. Click OK to accept this action.
If you do require the Internet Mail Service, and are not familiar with the configuration of it, follow the steps above.
After these steps are completed, and still within the Exchange Administrator program, click File, click New Other, click Internet Mail Service, and then proceed through the Internet Mail Service Wizard.
Reference LinksExchange Internet Mail Service Fails to Start on Default SBS 4.0 Installation

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