Event ID - 35

Event Id35
SourceMicrosoft-Windows-TerminalServices-PnPDevices
DescriptionDevice %1 is not supported on this machine, a generic driver is loaded.
Event InformationAccording to Microsoft:
Cause :
This event is logged when device is not supported on this machine.
Resolution :
Install a different driver for the device
To resolve this issue, install the driver provided by the device’s manufacturer. Check with the device’s manufacturer to determine if the driver has been updated to support device redirection in Terminal Services.
Note: When a device is connected, an attempt is made to find a driver on the terminal server that exactly matches the hardware identification number of the device. If an exact match cannot be found, a generic driver, chosen based on the device's compatible ID, is loaded on the terminal server instead. The generic driver may provide only limited functionality for the device.
To install the driver from the device manufacturer on the terminal server, use either of the following methods.
To perform these procedures, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
Method one
Run the Setup program for the device to install the device’s driver .inf file on the terminal server.
Method two
To install the driver by using Device Manager:
1.On the terminal server, open Device Manager. To open Device Manager, click Start, click Run, type devmgmt.msc, and then click OK.
2.If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
3.On the View menu, click Devices by connection.
4.Locate the device under the User Mode Bus controller node.
5.Right-click the name of the device, and then click Update Driver Software.
6.Click Browse my computer for driver software.
7.Specify the location of the driver from the device’s manufacturer, and then click Next.
8.Follow the instructions to complete the update of the driver.
Verify :
To verify that supported Plug and Play device redirection is working properly, use either of the following methods:
Method one
Establish a remote session with the terminal server and check that the redirected device is available and is functioning as expected.
Method two
Check the status of the device by using Device Manager.
To perform this procedure, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
To use Device Manager to check the status of the device:
1.On the terminal server, open Device Manager. To open Device Manager, click Start, click Run, type devmgmt.msc, and then click OK.
2.If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
3.On the View menu, click Devices by connection.
4.Locate the device under the User Mode Bus controller node.
5.Double-click the device and verify that Device status indicates that the device is working properly.
Reference LinksEvent ID 35 from Source Microsoft-Windows-TerminalServices-PnPDevices

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