Event ID - 30

Event Id30
SourceMicrosoft-Windows-PrintBRM
DescriptionThe language monitor in the backup file is for a different processor architecture than the destination computer, and Printbrm.exe (the Printer Migration Wizard or the command-line tool) could not locate and install a native version of the language monitor. Source architecture: %1. Destination architecture: %2. Install a native version of the language monitor on the destination computer and then retry importing the print queues.
Event Information According to Microsoft :

Cause :

This event is logged when language monitor in the backup file is for a different processor architecture than the destination computer, and Printbrm.exe (the Printer Migration Wizard or the command-line tool) could not locate and install a native version of the language monitor.

Resolution :

Install a printer driver that matches the server's processor architecture

Install a printer driver that matches the server's processor architecture. To do this, use either of the following procedures.

To install a printer driver on a server while logged on locally or by using a Remote Desktop connection:
  1. Log on locally or by using a Remote Desktop connection to the print server to which you want to add the printer drivers.
  2. Install the printer driver:

    • To install a printer driver not included with Windows, follow the instructions provided with the printer driver.
    • To install a new driver included with Windows, right-click the printer with the driver that you want to change or update, click Properties , and then click the Advanced tab.
    • Select a new driver in the Driver box, or click New Driver to install a new driver.

  3. Retry importing the print queue or queues.
To install a printer driver remotely on a server by using the Print Management snap-in:
  1. Log on to a client computer that uses the same processor architecture as the printer drivers that you want to add to the print server.
  2. To install a printer driver not included with Windows, follow the instructions provided with the printer driver.
  3. Open the Administrative Tools folder, and then double-click Print Management .
  4. Click Print Servers , click the appropriate print server, right-click Drivers , and then click Add Driver .
  5. Use the Add Printer Driver Wizard to install the appropriate drivers. You might have to click Have Disk on the Printer Driver Selection page and then specify the path for the driver's .inf file. Windows automatically uploads the drivers from the client computer to the print server.
  6. Retry importing the print queue or queues.
Note : To support client computers that use processor architectures that are different from the one used by the print server, you must install additional drivers. To add client printer drivers to the print server, click the Sharing tab in the Properties dialog box and then click Additional Drivers .

Verify :

To confirm that print queues and all settings were successfully imported, perform the following tasks:
  • Confirm that all of the print queues that you exported from the source print server are listed in the Printers folder in Control Panel on the destination server to which you imported the print queues.
    If you have a large number of printers to compare, export a list of printers on the server from which you exported the print queues. Then export a list of printers from the server on which you imported the files, and then compare the results in Microsoft Excel or another spreadsheet program. To export a list of printers from a server, use the following procedure:

    1. On a computer running Windows Vista Business, Windows Vista Enterprise, Windows Vista Ultimate, or Windows Server 2008, open the Print Management snap-in from the Administrative Tools folder.
    2. In the Print Management tree, click the name of the computer that contains the printer queues that you exported (if available), right-click Printers , and then click Export List .
    3. Specify a file name for the list of printers, and then click Save .

  • Test printing to each printer. All documents should print properly.
  • Confirm that each printer is shared and accessible from other computers on the network and has the appropriate printer preferences for your environment.
  • Confirm that the printer was successfully published to Active Directory Domain Services (AD DS), if appropriate.
To do this, look for Print Spooler Event 36 or Print Spooler Event 40 in Event Viewer (if the print server logs spooler information events), or use the following procedure to search AD DS for the printer:
  1. On a computer in the same domain as the print server, open the Printers folder in Control Panel and then click Add a printer . The Add Printer Wizard appears.
  2. Select A printer that is not attached to my computer (a network printer) , and then click Next .
  3. Click The printer I am looking for is not on this list .
  4. Select Find a printer in Active Directory, based on location or feature , click Next , and then use the Find Printers dialog box to search AD DS for the printer.
Reference LinksEvent ID 30 from Source Microsoft-Windows-PrintBRM

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