Event ID - 2201

Event Id2201
SourceMSMQ
DescriptionMessage Queuing Triggers initialization failed. Error %1: %2
Event Information According to Microsoft :

Cause :

This event is logged when Message Queuing Triggers initialization failed.

Resolution :

Confirm registry key and permissions

Message Queuing needs full permission on its registry node. The Message Queuing Triggers service will fail to start if Message Queuing is not able to read certain information from the registry.

You must run the registry editor as an administrator, which is the only way to edit registry keys with the user interface (UI). By default, local administrators have full permissions on the entire registry.

To confirm the registry key and permissions:

Caution : Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.
  1. Open Registry Editor. To open Registry Editor, click Start . In the search box, type regedit , and then press ENTER.
  2. Expand HKEY_LOCAL_MACHINE , expand SOFTWARE , expand Microsoft , and then expand MSMQ .
  3. Confirm that the Triggers registry key is available and that Message Queuing can read the registry values.
  4. Right-click the MSMQ Registry node (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ) , and then click Permissions .
  5. In Group or user names , confirm that MSMQ is included. If it is not included, click Add .
    In Group or user names , click MSMQ , and then click Advanced .
  6. In Permission entries , click MSMQ , and then click Edit .
  7. For Full Control , confirm that MSMQ has the Allow check box selected. This action selects all the other Allow check boxes.
  8. In the Apply to list, confirm that This key and subkeys is selected.
If you continue to receive this error, note any details in the event message, and then contact Microsoft Customer Service and Support (CSS).

Verify :

Verify that the Message Queuing Triggers service is installed and running.

To perform this procedure, you must have membership in Administrators , or you must have been delegated the appropriate authority.

To verify that the Message Queuing Triggers service is installed and running:
  1. Open the Services snap-in. To open Services, click Start . In the search box, type services.msc , and then press ENTER.
  2. Scroll down the list of services to confirm the presence of the Message Queuing Triggers service.
  3. In the Status column, confirm that the Message Queuing Triggers service is Started .
Reference LinksEvent ID 2201 from MSMQ

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.