Event ID - 2195

Event Id2195
SourceMSMQ
DescriptionMessage Queuing could not authenticate a message sent to queue %1. The message was rejected because the queue only accepts authenticated messages. A negative arrival acknowledgement will be sent if requested by the sender. This event is logged at most once per %2 seconds. To change this setting, set \HKLM\Software\Microsoft\MSMQ\Parameters\Event2195 registry value to desired time in seconds.
Event Information According to Microsoft :

Cause :

This event is logged when Message Queuing could not authenticate a message sent to queue.

Resolution :

Confirm that messages are authenticated and that the sending computer has a valid certificate

Because the queue accepts only authenticated messages, messages that are sent to the queue must be authenticated and signed with a certificate, which is registered in Active Directory Domain Services (AD DS).

To perform this procedure, you must have membership in Administrators , or you must have been delegated the appropriate authority.

To confirm the presence of user certificates:
  1. On any computer in the domain, click Start . In the search box, type compmgmt.msc , and then press ENTER.
  2. Enter administrator credentials, if you are prompted, and then continue through the User Access Control messages.
  3. Navigate to the Message Queuing console tree. Click Services and Applications , and then click Message Queuing .
  4. Right-click Message Queuing , and then click Properties .
  5. Click the User Certificate tab.
  6. Click View .
  7. Determine whether the computer sending the unauthenticated messages is in the Personal Certificates list.
  8. If the computer is not in the list, a certificate was not registered.
  9. You can fix this by performing steps 1 through 7 on the computers on which the certificate was not registered. For step 6, click Register instead of View .
Verify :

Verify that the MSMQ Service is installed and running.

To perform this procedure, you must have membership in Administrators , or you must have been delegated the appropriate authority.

To verify that the MSMQ Service is installed and running:
  1. Open the Services snap-in. To open Services, click Start . In the search box, type services.msc , and then press ENTER.
  2. Locate the Message Queuing service, and then confirm that the value in the Status column is Started .
Reference LinksEvent ID 2195 from MSMQ

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