Event ID - 2165

Event Id2165
SourceMSMQ
DescriptionThe sites where the computer resides cannot be resolved. Check that the subnets in your network are configured correctly in Active Directory and that each site is configured with the appropriate subnet.
Event Information According to Microsoft :

Cause :

This event is logged when the sites where the computer resides cannot be resolved.

Resolution :

Ensure that subnets are configured correctly

The subnets may not be configured correctly. Possible actions include the following:
  • Reconfigure the Active Directory subnets in your network.
  • Configure each site with the appropriate subnet.
Contact your domain administrator to resolve these issues.

Verify :

You can confirm the presence of the Directory Service Integration feature by doing the following:
  • Verify the registry key setting
  • Verify that the computer is joined to the correct domain
  • Verify Active Directory operation
To perform these procedures, you must have membership in Administrators , or you must have been delegated the appropriate authority.

Caution : Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.

Verify the registry key setting

To verify the registry key setting:
  1. Open Registry Editor. To open Registry Editor, click Start . In the search box, type regedit , and then press ENTER.
  2. In Registry Editor, expand HKEY_LOCAL_MACHINE , expand SOFTWARE , expand Microsoft , expand MSMQ , and then click Setup .
  3. In the details pane, double-click msmq_ADIntegrated .
  4. Confirm that Value data is set to 1 .
  5. Under MSMQ , expand Parameters .
  6. In the details pane, double-click Workgroup .
  7. Confirm that Value data is not set to 1 .
Verify that the computer is joined to the correct domain

To verify that the computer is joined to the correct domain:
  1. Open Server Manager. To open Server Manager, click Start , point to Administrative Tools , and then click Server Manager .
  2. Confirm that the domain that is listed in Computer Information is the correct domain.
Verify Active Directory operation

You can confirm that Active Directory is operating correctly by verifying that the Public Queue feature is enabled in Message Queuing.

To verify that the Public Queue feature is enabled:
  1. Open the Computer Management snap-in. To open Computer Management, click Start . In the search box, type compmgmt.msc , and then press ENTER.
  2. Navigate to MSMQ .
  3. If the Public Queues folder exists and you can right-click the folder, Message Queuing is operating correctly in domain mode with Active Directory Integration.
  4. For further confirmation, run a test application that uses the Active Directory features that you require.
Reference LinksEvent ID 2165 from MSMQ

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