Event ID - 2164

Event Id2164
SourceMSMQ
DescriptionThe Message Queuing service will not join the %1 domain. An MSMQ Configuration (msmq) object exists in the new domain with an ID differing from the service ID.
Event InformationAccording to Microsoft :
Cause :
This event is logged when the Message Queuing service will not join the domain.
Resolution :
Remove stale Active Directory objects
Stale objects can prevent the MSMQ Service from operating properly. Deleting stale objects may solve this problem. However, deleting a computer object in Active Directory Domain Services (AD DS) can cause problems on the client computer. Before deleting the computer object, make sure that no services running on the client computer will be affected. In this case, deleting the Message Queuing Active Directory object will delete public queues on that computer.
You must have the Active Directory services tools installed in Role Administration tools under Remote Server Administration.
To perform these procedures, you must have membership in Administrators, or you must have been delegated the appropriate authority.
Confirm that Active Directory services and control components are installed
To confirm that Active Directory services and control components are installed properly:
1.Click Start, point to Administrative Tools, right-click Active Directory Users and Computers,and then click Run as administrator.
2.Confirm that the following Active Directory tools appear in the list:
a)Active Directory Domains and Trusts
b)Active Directory Sites and Services
c)Active Directory Users and Computers
Delete stale computer objects
To delete stale computer objects:
1.Click Start, point to Administrative Tools, right-click Active Directory Users and Computers,and then click Run as administrator.
2.On the View menu, ensure that Users, Contacts, Groups and Computers as containers is selected and that Advanced Features is selected.
3.Browse to the particular computer. Check whether there are Message Queuing objects present under that computer.
4.If there are Message Queuing objects and Message Queuing with Active Directory integration is not installed on that particular computer, these objects are stale. Delete the particular Message Queuing Active Directory object, and then restart the MSMQ Service or, if necessary, restart the computer.
Verify :
You can confirm the presence of the Directory Service Integration feature by doing the following:
a)Verify the registry key setting
b)Verify that the computer is joined to the correct domain
c)Verify Active Directory operation.
To perform these procedures, you must have membership in Administrators, or you must have been delegated the appropriate authority.
Caution:
Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.
Verify the registry key setting
To verify the registry key setting:
1.Open Registry Editor. To open Registry Editor, click Start. In the search box type regedit, and then press ENTER.
2.In Registry Editor, expand HKEY_LOCAL_MACHINE, expand SOFTWARE, expand Microsoft, expand MSMQ, and then click Setup.
3.In the console tree, double-click msmq_ADIntegrated.
4.Confirm that Value data is set to 1.
5.Under MSMQ, expand Parameters.
6.In the details pane, double-click Workgroup.
7.Verify that Value data is not set to 1.
Verify that the computer is joined to the correct domain
To verify that the computer is joined to the correct domain:
1.Open Server Manager. To open Server Manager, click Start, point to Administrative Tools, and then click Server Manager.
2.Verify that the domain that is listed in the Computer Information is the correct domain.
Verify Active Directory operation
You can confirm that Active Directory Domain Services (AD DS) is operating correctly by verifying that the Public Queue feature is enabled in Message Queuing.
To verify that the Public Queue feature is enabled in Message Queuing:
1.Open the Computer Management snap-in. To open Computer Management, click Start. In the search box, type compmgmt.msc, and then press ENTER.
2.Navigate to MSMQ.
3.If the Public Queues folder exists and you can right-click the folder, Message Queuing is operating correctly in domain mode with Active Directory Integration.
4.For further confirmation, run a test application that uses the Active Directory features that you require.
Reference LinksEvent ID 2164 from Source MSMQ

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