Event ID - 2154

Event Id2154
SourceMSMQ
DescriptionA multicast listener initialization failed. The file '%3' may be corrupted. Error %1: %2
Event Information According to Microsoft :

Cause :

This event is logged when a multicast listener initialization failed.

Resolution :

Recreate message queues

Mulitcast listener failed on one or more files. This may indicate that the store is corrupt. Try deleting the queues (through the file system or the directory service) for which such errors are generated, and then restart Message Queuing. Before you delete a queue, make sure that the queue is empty and that Message Queuing is offline.

To perform these procedures, you must have membership in Administrators , or you must have been delegated the appropriate authority.

Delete a queue

To delete a queue:
  1. Open the Computer Management snap-in. To open Computer Management, click Start . In the search box, type compmgmt.msc , and then press ENTER.
  2. In the console tree, expand Services and Applications .
  3. Right-click Message Queuing , point to All Tasks , and then click Take Message Queuing Offline .
  4. Right-click the desired queue, and then click Delete .
Restart Message Queuing and recreate a queue

To restart Message Queuing and recreate a queue:
  1. Open the Services snap-in. To open Services, click Start . In the search box, type services.msc , and then press ENTER.
  2. Right-click Message Queuing , and then click Restart . You must restart all the dependent services, as well.
  3. Open the Computer Management snap-in. To open Computer Management, click Start . In the search box, type compmgmt.msc , and then press ENTER.
  4. In the console tree, expand Services and Applications , and then select Message Queuing .
  5. Right-click Public Queue or Private Queue , and then click New .
  6. Create your queue with the correct settings.
  7. Right-click Message Queueing , click All Tasks , and then click Bring Message Queuing Online .
Verify :

Verify that the MSMQ Service is installed and running.

To perform this procedure, you must have membership in Administrators , or you must have been delegated the appropriate authority.

To verify that the MSMQ Service is installed and running:
  1. Open the Services snap-in. To open Services, click Start . In the search box, type services.msc , and then press ENTER.
  2. Locate the Message Queuing service, and then confirm that the value in the Status column is Started .
  3. For further confirmation, run a test application that uses the Active Directory features that you require.
Reference LinksEvent ID 2154 from MSMQ

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.