Event ID - 2145

Event Id2145
SourceMSMQ
DescriptionThe computer object for this computer was not found in Active Directory, possibly because of Active Directory replication delays.
Event InformationAccording to Microsoft :
Cause :
This event is logged when the computer object for this computer was not found in Active Directory.
Resolution :
Configure replication delays
There is an issue with replication delays. This issue should be resolved after Active Directory Domain Services (AD DS) replicates itself. After replication is complete, try to create the Active Directory object again:
a)For smaller networks, replication should take a few minutes.
b)For larger networks, the replication may take a long time.
Advanced users and domain administrators can also use the Knowledge Consistency Checker (KCC) to configure replication delays.
Verify :
You can confirm the presence of the Directory Service Integration feature by doing the following:
a)Verify the registry key setting
b)Verify that the computer is joined to the correct domain
c)Verify Active Directory operation.
To perform these procedures, you must have membership in Administrators, or you must have been delegated the appropriate authority.
Caution:
Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.
Verify the registry key setting
To verify the registry key setting:
1.Open Registry Editor. To open Registry Editor, click Start. In the search box type regedit, and then press ENTER.
2.In Registry Editor, expand HKEY_LOCAL_MACHINE, expand SOFTWARE, expand Microsoft, expand MSMQ, and then click Setup.
3.In the console tree, double-click msmq_ADIntegrated.
4.Confirm that Value data is set to 1.
5.Under MSMQ, expand Parameters.
6.In the details pane, double-click Workgroup.
7.Verify that Value data is not set to 1.
Verify that the computer is joined to the correct domain
To verify that the computer is joined to the correct domain:
1.Open Server Manager. To open Server Manager, click Start, point to Administrative Tools, and then click Server Manager.
2.Verify that the domain that is listed in the Computer Information is the correct domain.
Verify Active Directory operation
You can confirm that Active Directory Domain Services (AD DS) is operating correctly by verifying that the Public Queue feature is enabled in Message Queuing.
To verify that the Public Queue feature is enabled in Message Queuing:
1.Open the Computer Management snap-in. To open Computer Management, click Start. In the search box, type compmgmt.msc, and then press ENTER.
2.Navigate to MSMQ.
3.If the Public Queues folder exists and you can right-click the folder, Message Queuing is operating correctly in domain mode with Active Directory Integration.
4.For further confirmation, run a test application that uses the Active Directory features that you require.
Reference LinksEvent ID 2145 from Source MSMQ

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.