Event ID - 204

Event Id204
SourceMicrosoft-Windows-SpoolerTCPMon
DescriptionUnable to initialize standard TCP/IP printer port %1.
Event Information According to Microsoft :

Cause :

This event is logged when unable to initialize standard TCP/IP printer port.

Resolution :

Close programs or restart the print server

To resolve this issue, use the following procedure:
  1. Close all unecessary programs, and then retry printing the document.
  2. If problems persist, determine whether the computer is low on system resources such as CPU resources, disk I/O performance, or memory.
    To identify what is causing the system to be low on resources, you can generate a System Diagnostics Report using Reliability and Performance Monitor, or you can use Resource Monitor to determine (in real time) which applications or services are utilizing too many system resources. For more information, see the "Generate a System Diagnostics Report" and "Start Resource Monitor" sections later in this topic.
  3. Use Task Manager to close any programs that have stopped responding, or to end any processes left behind by unresponsive programs.
  4. Restart the server, if necessary.
To perform these procedures, you must have membership in Administrators , or you must have been delegated the appropriate authority.

Generate a System Diagnostics Report

To collect system information for 60 seconds and generate a System Diagnostics Report:
  1. Open an elevated Command Prompt window. (Click Start , point to All Programs , click Accessories , right-click Command Prompt , and then click Run as administrator .)
  2. At the command prompt, type perfmon /report and then press ENTER. Reliability and Performance Monitor will start collecting data to create the System Diagnostics Report.
  3. When the report is ready for viewing, locate the Diagnostic Results section of the report, and then check for any warnings (indicated by Warning in the report). You can follow links to additional help on resolving warnings from this section. In addition, you can expand each category in the Basic System Checks section to see more details about why warnings appear. Also, the Performance section provides process-level details about top consumers of resources.
Start Resource Monitor

To start Resource Monitor:

Important : Resource Monitor stops collecting information while a System Diagnostics Report is being generated. To start collecting information after a System Diagnostics Report has been completed, click Start in Monitor .
  1. Open an elevated Command Prompt window. (Click Start , point to All Programs , click Accessories , right-click Command Prompt , and then click Run as administrator .)
  2. At the command prompt, type perfmon /res and then press ENTER. Resource Monitor will start running.
  3. Four scrolling graphs in the Resource Overview pane display the real-time usage of CPU, Disk, Network, and Memory. Four expandable sections below the graphs contain process-level detail about each resource. Click the resource labels to see more information, or click a graph to expand its corresponding details. You can use the real-time usage information to identify top resource consumers. Click a column heading to sort the data in the table by that column; click the column heading again to reverse the sort order.
Verify :

Retry printing to the printer, using the standard TCP/IP printing port monitor.
Reference LinksEvent ID 204 from Source Microsoft-Windows-SpoolerTCPMon

Catch threats immediately

We work side-by-side with you to rapidly detect cyberthreats
and thwart attacks before they cause damage.

See what we caught

Did this information help you to resolve the problem?

Yes: My problem was resolved.
No: The information was not helpful / Partially helpful.