Event ID - 2035

Event Id2035
SourceMSMQ
DescriptionThe Message Queuing service cannot start. The Active Directory interface cannot be initialized. Error %1: %2
Event InformationAccording to Microsoft :
Cause :
This event is logged when the Message Queuing service cannot start.
Resolution :
Repair Active Directory interface issues
There may be several reasons why the Active Directory interface cannot be initialized. Possible actions include the following:
a)Configuring Message Queuing objects to be accessible in Active Directory Domain Services (AD DS).
b)Making modifications so that Message Queuing can find and bind to the directory service.
c)Resolving issues that are preventing Message Queuing from synchronizing with AD DS.
Verify :
You can confirm the presence of the Directory Service Integration feature by doing the following:
a)Verify the registry key setting
b)Verify that the computer is joined to the correct domain
c)Verify Active Directory operation
Note:
To perform these procedures, you must have membership in Administrators, or you must have been delegated the appropriate authority.
Caution: Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.
Verify the registry key setting
To verify the registry key setting:
1.Open Registry Editor. To open Registry Editor, click Start. In the search box, type regedit, and then press ENTER.
2.In Registry Editor, expand HKEY_LOCAL_MACHINE, expand SOFTWARE, expand Microsoft, expand MSMQ, and then click Setup.
3.In the details pane, double-click msmq_ADIntegrated.
4.Confirm that Value data is set to 1
5.Under MSMQ, expand Parameters.
6.In the details pane, double-click Workgroup.
7.Confirm that Value data is not set to 1.
Verify that the computer is joined to the correct domain
To verify that the computer is joined to the correct domain:
1.Open Server Manager. To open Server Manager, click Start, point to Administrative Tools, and then click Server Manager.
2.Confirm that the domain that is listed in Computer Information is the correct domain.
Verify Active Directory operation
You can confirm that Active Directory is operating correctly by verifying that the Public Queue feature is enabled in Message Queuing.
To verify that the Public Queue feature is enabled:
1.Open the Computer Management snap-in. To open Computer Management, click Start. In the search box, type compmgmt.msc, and then press ENTER.
2.Navigate to MSMQ.
3.If the Public Queues folder exists and you can right-click the folder, Message Queuing is operating correctly in domain mode with Active Directory Integration.
Reference LinksEvent ID 2035 from Source MSMQ

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