Event ID - 20202

Event Id20202
SourceRemoteAccess
DescriptionAn error occured while trying to revert impersonation.
Event Information According to Microsoft :

Cause :

This event is logged when an error occured while trying to revert impersonation.

Diagnose :

This error might be caused by one of the following conditions:
  • The Routing and Remote Access service is unable to start because the PPP protocol was not initialized. This might have occurred for one of the following reasons:
  • The remote access service failed to load rasppp.dll. See the section titled "Check the availability of rasppp.dll."
  • The remote access service failed to load the entry\exit function of PPP.
  • Incorrect configuration or lack of resources. See the section titled "Disconnect and retry the remote access connection, check network services, or check NAP."

  • The Routing and Remote Access service is unable to initialize the RPC service.
  • The dynamic-link library (DLL) did not implement one of the following functions: RasCpInit, RasCpEnumProtocolIds, RasCpGetInfo, RasEapGetInfo.
Check whether the SYSTEM account has read and execute permissions for the file %systemroot%\system32\rasppp.dll.

To check the permissions of the SYSTEM account:
  1. Right-click rasppp.dll, and then click Properties .
  2. On the Securities tab, confirm that the SYSTEM account has read and execute permission and that read permission is set to Allow .
Resolution :

Check the availability of rasppp.dll

Confirm that rasppp.dll exists at %systemRoot%\system32. If the dynamic-link library (DLL) does not exist at this location, you might need to repair or reinstall the Windows operating system.

Disconnect and retry the remote access connection, check network services, or check NAP

Possible resolutions:
  • Disconnect and retry the remote access connection.
  • Check that network services such as firewall services, NAP Agent, antivirus, system health validators (SHVs), and system health agents (SHAs) are running.
  • Make a Network Access Protection (NAP) connection, change the statement of health (SoH), and then check if the issue still exists.
Verify :

To verify that the remote access server can accept connections, establish a remote access connection from a client computer.

To create a VPN connection:
  1. Click Start , and then click Control Panel .
  2. Click Network and Internet , click Network and Sharing Center , and then click Set up a connection or network .
  3. Click Connect to a workplace , and then click Next .
  4. Complete the steps in the Connect to a Workplace wizard.
To connect to a remote access server:
  1. In Network and Sharing Center, click Manage network connections .
  2. Double-click the VPN connection, and then click Connect .
  3. Verify that the connection was established successfully.
Reference LinksEvent ID 20202 from RemoteAccess

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