Event ID - 20127

Event Id20127
SourceRemoteAccess
DescriptionThe demand-dial interface: %1 was not loaded. The router was not started in demand-dial mode.
Event Information According to Microsoft :

Cause :

This event is logged when demand-dial interface was not loaded.

Diagnose :

This error might be caused by one of the following conditions:
  • The network interface is disabled or not connected to a network.
  • The Routing and Remote Access service is stopped.
To perform this procedure, you must be a member of the Administrators group, or you must have been delegated the appropriate authority.

Network interface is disabled or not connected to a network
  1. Confirm that the network interface card is physically connected to a network.
  2. Open Network Connections, and check the status of the network device.
  3. If the status is Disabled or Unplugged , see the section titled "Enable network devices or services" or "Check the network connection."
Routing and Remote Access service is stopped
  1. Open Routing and Remote Access. Click Start , click Run , type rrasmgmt.msc , and then press ENTER.
  2. In the console tree, click Server Status .
  3. Determine if the status of the Remote Access service is started.
  4. If the Remote Access service is stopped, see the section titled "Enable network devices or services."
Resolution :

Enable network devices or services

To perform thes procedures, you must be a member of the Administrators group, or you must have been delegated the appropriate authority.

Enable the network interface

To enable the network interface:
  1. Open Network Connections, and check the status of the network device.
  2. Right-click the network device, and then click Enable.
Start the Routing and Remote Access service

To start the Routing and Remote Access service:
  1. Open Routing and Remote Access. Click Start , click Run , type rrasmgmt.msc , and then press ENTER.
  2. In the console tree, click Server Status .
  3. In the details pane, right-click a server name, point to All Tasks , and click Start .
Configure ports for remote access

To perform this procedure, you must be a member of the Administrators group, or you must have been delegated the appropriate authority.

To configure ports for remote access:
  1. Open Routing and Remote Access. Click Start , click Run , type rrasmgmt.msc , and then press ENTER.
  2. In the console tree, right-click Ports .
  3. Click Properties .
  4. In the Ports Properties dialog box, click a device, and then click Configure .
  5. In the Configure Device dialog box, do one or both of the following:
  • To enable remote access, select the Remote access connections (inbound only) check box.
  • To enable demand-dial routing, select the Demand-dial routing connections (inbound and outbound) check box.
Review the remote access service error code

There is not enough information available in the Routing and Remote Access service event message to provide a recommendation for the resolution of the problem. If you continue to get this error, contact Microsoft Product Support Services.

Check the availability and response of the modem or other connection device

Possible resolutions include:
  • the modem was disconnected or turned off, reconnect or turn on your modem, and then either restart the operating system or use Device Manager to scan for new hardware.
  • If the communications port is already in use by another connection, end the connection or change the connection to use a different port.
Configure dial-out time restriction

To perform this procedure, you must be a member of the Administrators group, or you must have been delegated the appropriate authority.

To configure dial-out hours:
  1. Open Routing and Remote Access. Click Start , click Run , type rrasmgmt.msc , and then press ENTER.
  2. In the console tree, click Network Interfaces . In the details pane, right-click the demand-dial interface you want to configure, and then click Dial-out Hours .
  3. In the Dial-out Hours dialog box, select the appropriate day and time boxes to either permit or deny dial-out access, click either Permitted or Denied , and then click OK .
Check the network interface card

Reconnect or reinstall the network interface card used for remote connections.

Check the network connection

Reconnect the network interface card used for remote connections.

Upgrade the operating system

Upgrade the operating system on the remote access server to an operating system that supports demand-dial interfaces, such as Windows Server 2003 or Windows Server 2008.

Verify :

To verify that the remote access server can accept connections, establish a remote access connection from a client computer.

To create a VPN connection:
  1. Click Start , and then click Control Panel .
  2. Click Network and Internet , click Network and Sharing Center , and then click Set up a connection or network .
  3. Click Connect to a workplace , and then click Next .
  4. Complete the steps in the Connect to a Workplace wizard.
To connect to a remote access server:
  1. In Network and Sharing Center, click Manage network connections .
  2. Double-click the VPN connection, and then click Connect .
  3. Verify that the connection was established successfully.
Reference LinksEvent ID 20127 from RemoteAccess

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