Event ID - 20031

Event Id20031
SourceRemoteAccess
DescriptionThe Remote Access Connection Manager service failed to start because it could not locate port information from media DLLs. %1
Event Information According to Microsoft :

Cause :

This event is logged when the Remote Access Connection Manager service failed to start because it could not locate port information from media DLLs.

Resolution :

Check the media DLLs or reinstall the Routing and Remote Access service

Media dynamic-link libraries (DLLs) are defined at HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rasman\Parameters\Medias. Confirm that the DLL required for the communication device exists at %systemroot%\system32.

In Device Manager, check whether the communication device is installed correctly. If there is a driver problem, a yellow excalamation mark will be displayed for the hardware device. Try reinstalling the driver and then restart the computer.

If the problem persists, reinstall the Routing and Remote Access service.

To perform these procedures, you must have membership in Administrators , or you must have been delegated the appropriate authority.

Uninstall Routing and Remote Access service

To uninstall Routing and Remote Access service:
  1. In Server Manager, under Roles Summary , click Remove Roles .
  2. In the Remove Roles Wizard, click Next .
  3. In the list of server roles, select Network Policy and Access Services to clear the check box.
  4. Click Next , and then click Remove .
Install Routing and Remote Access service

To install Routing and Remote Access service:
  1. In Server Manager, under Roles Summary , click Add Roles .
    -- OR --
    In the Initial Configuration Tasks window , under Customize This Server , click Add Roles .
  2. In the Add Roles Wizard, click Next .
  3. In the list of server roles, select Network Policy and Access Services . Click Next twice.
  4. In the list of role services, select Routing and Remote Access Services to select all of the role services. You can also select individual server roles.
  5. Follow the steps in the Add Roles Wizard to complete the installation of the Routing and Remote Access service.
Verify :

You can verify that Remote Access Connection Manager is working by checking the installation or service status.

To check the status of the Remote Access Connection Manager service:
  1. Open Server Manager. Click Start , point to Administrative Tools , and then click Server Manager .
  2. In the navigation pane, double-click Diagnostics , and then click Services .
  3. In the details pane, verify that the Remote Access Connnection Manager service is installed and started.
Note : If the Remote Access Connection Manger service does not appear in the list of services, you might have to repair or reinstall the operating system. If you cannot start the Remote Access Connection Manager service, restart the computer.
Reference LinksEvent ID 20031 from RemoteAccess

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