Event ID - 1184

Event Id1184
SourceMicrosoft-Windows-ActiveDirectory_DomainService
DescriptionAD_TERM was unable to delete the index for the following attribute. Attribute name:%1 Attribute ID:%2 This index is no longer needed. Additional Data Error value:%3 %4
Event InformationAccording to Microsoft :
Cause :
This event is logged when the AD_TERM was unable to delete the index for the following attribute.
Resolution :
Look for Event ID 1136 in Event Viewer
This is a general error message indicating that there may be an issue related to schema attribute indexing. If there is an issue, Event ID 1136 appears in Event Viewer. Use the additional information in that event to resolve the issue.
Verify :
To verify that the schema is in a consistent state, complete the following procedures:
  1. Ensure that the domain controllers synchronize their directory data by starting Active Directory replication.
  2. Enable diagnostic logging for the schema.
  3. Update the schema cache.
  4. Verify that the schema was updated successfully by using Event Viewer.
To perform these procedures, you must have membership in Domain Admins, or you must have been delegated the appropriate authority.
Start Active Directory replication
To start Active Directory replication:
  1. Open a command prompt as an administrator. To open a command prompt as an administrator, click Start. In Start Search, type Command Prompt. At the top of the Start menu, right-click Command Prompt, and then click Run as administrator. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  2. Run the command repadmin /syncall /user:domain\user /pw:password. Substitute the appropriate domain name, user name, and password for domain, user, and password, respectively. The command output indicates whether synchronization started successfully.
Enable diagnostic logging for the schema
To verify a successful update of the schema, you can enable diagnostic logging for the schema. When you enable diagnostic logging, a schema update produces Event ID 1582 in the Directory Service log of Event Viewer. To enable diagnostic logging for the schema, you must edit the registry.
To enable diagnostic logging for the schema:
  1. Open Registry Editor. To open Registry Editor, click Start. In Start Search, type regedit, and then press ENTER. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  2. In the registry location HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Diagnostics, in the left pane, right-click the 24 DS Schema value, and then click Modify.
  3. Type 1 or higher (up to 5) for Value data to enable diagnostic logging for the schema. The higher the value, the more information is reported to the Directory Service log.Click OK.
Update the schema cache
To update the schema cache:
  1. Create a file to force a schema cache update using Ldifde.exe. Create a new text file named SchemaUp (SchemaUp.txt, if you are viewing file extensions) in a folder location that is convenient for you to access.
  2. Copy the following five lines of text and paste them as the contents of the SchemaUp.txt file.
    dn:
    changetype: modify
    add: schemaUpdateNow
    schemaUpdateNow: 1
  3. After you paste the text to the file, ensure that there are no line breaks (carriage returns) between each line of text. If there are line breaks, delete the empty lines. Ensure that you have a hyphen as the last line of text in the file.
  4. Save the file.
  5. Open a command prompt as an administrator. To open a command prompt as an administrator, click Start. In Start Search, type Command Prompt. At the top of the Start Menu, right-click Command Prompt, and then click Run as administrator. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  6. At the command prompt, type ldif -i -f SchemaUp.txt, and then press ENTER. If necessary, type the file path to the text file that you saved.
Verify that the schema cache was updated successfully by using Event Viewer
To verify that the schema cache was updated successfully by using Event Viewer:
  1. Open Event Viewer. To open Event Viewer, click Start. In Start Search, type eventvwr.msc, and then press ENTER.
  2. Expand Applications and Services Logs, and then click Directory Service.
  3. Look for Event ID 1582, which confirms that the schema cache was reloaded successfully. If you do not see the event, click Find, type 1582, and then click Find Now. Event 1582 confirms that the schema cache was updated.
  4. Confirm that there are no Critical, Error, or Warning events that are related to the schema that occurred after the schema cache update. To locate events that are related to the schema, click Find, type DS Schema, and then click Find Next.
  5. Continue to click the Find Next button and review each event until you have verified that there are no Critical, Error, or Warning events that occurred after the schema cache update.
When you confirm that the schema cache was updated, you may no longer need diagnostic logging for schema events. To disable diagnostic logging for schema events, use the Reg command to set the 24 DS Schema value to 0. To set the value of 24 DS Schema to 0, at a command prompt, type the following command, and then press ENTER:
Reg Add HKLM\SYSTEM\CurrentControlSet\Services\NTDS\Diagnostics /v "24 DS Schema" /t REG_DWORD /d 0
The number after /d indicates the value, in this case, the logging level.
To learn more about the Reg command syntax and options, at a command prompt, type Reg /?, and then press ENTER.
Reference LinksEvent ID 1184 from Source Microsoft-Windows-ActiveDirectory_DomainService

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