Event ID - 1142

Event Id1142
SourceMicrosoft-Windows-ActiveDirectory_DomainService
DescriptionInternal event: The auxiliary class identifier for the following schema class is not valid. Auxiliary class identifier:%3 Class identifier:%1 Class name:%2 The auxiliary class identifier is pointing to a class that does not exist, and the auxiliary class will be ignored.
Event InformationAccording to Microsoft :
Cause :
This event is logged when the auxiliary class identifier for the schema class is not valid.
Resolution :
Start a replication sync with all replication partners of the local directory service
You can use the following procedures to resolve this issue. After you complete each procedure, check Event Viewer to see if Event IDs 1142 or 1156 continue to be reported. If either of these events continue to be reported, try the next procedure.
  1. Start Active Directory replication.
  2. Restore the Active Directory database from backup media.
To perform these procedures,must have membership in Domain Admins or must have been delegated the appropriate authority. Perform all steps on the computer that is logging the event to be resolved.
Start Active Directory replication
To start Active Directory replication:
  1. Open a command prompt as an administrator. To open a command prompt as an administrator, click Start. In Start Search, type Command Prompt. At the top of the Start menu, right-click Command Prompt, and then click Run as administrator. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  2. At the command prompt, type repadmin /syncall /user:domain\user /pw:password, and then press ENTER. Substitute the appropriate domain name, user name, and password for domain, user, and password, respectively. The command output indicates whether synchronization started successfully.
  3. At the command prompt, type time /t, and then press ENTER. This command displays the time at the server on which you are working.
  4. Wait at least 15 minutes before proceeding to the next step.
  5. Open Event Viewer. To open Event Viewer, click Start. In Start Search, type eventvwr.msc, and then press ENTER.
  6. Expand Applications and Services Logs, and then click Directory Service. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  7. Look for events that occurred after you started replication with the repadmin command. Search for the following event identifiers: 1142, 1153, 1154, 1155, and 1156, which indicate that there is still an issue with the schema. To search for event 1142, click Find, type 1142, and then click Find Now. Use the same steps to search for the other event identifiers.
  8. If you do not find any additional events related to the issue, it is probably solved. Check back in one hour and search for the events again. If they do not appear, check back in 24 hours.
  9. If you do find additional events that are related to the issue, restore the Active Directory database on the affected domain controller from backup media.
Restore the Active Directory database from backup media
To restore the Active Directory database from backup media,need the Directory Services Restore Mode password.If do not know the Directory Services Restore Mode password,can reset it by using the Ntdsutil tool
  1. At a command prompt that you opened as administrator, type bcdedit /set safeboot dsrepair, and then press ENTER.
  2. Restart the domain controller.
  3. At the Windows logon screen, click Switch User.
  4. Click Other User.
  5. Type .\administrator as the user name, type the Directory Services Restore Mode password for the server and then press ENTER.
  6. Click Start. In Start Search, type cmd, and then press ENTER.
  7. At the command prompt, type wbadmin get versions -backuptarget:targetDrive:, and then press ENTER. Substitute the location of the backup that you want to restore for targetDrive.
  8. Identify the version of the backup that you want to restore.Must enter this version exactly in the next step.
  9. Type wbadmin start systemstaterecovery -version:dateTime -backuptarget:targetDrive:-quiet, and then press ENTER. Substitute the version of the backup that you want to restore for dateTime and the volume that contains the backup for targetDrive.
  10. Open a command prompt, type bcdedit /deletevalue safeboot, and then press ENTER.
  11. After the recovery operation completes restart the domain controller.
Note : There is no need to attempt an authoritative restore because the schema cannot be restored by using an authoritative restore.
Reference LinksEvent ID 1142 from Source Microsoft-Windows-ActiveDirectory_DomainService

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