Event ID - 1124

Event Id1124
SourceMicrosoft-Windows-TerminalServices-Printers
DescriptionThe number of printers per session limit was reached. The following print queue was not created: Printer = %1 Port = %2
Event InformationAccording to Microsoft :
Cause :
This event is logged when the number of printers per session limit was reached.
Resolution :
Modify the MaxPrintersPerSession registry entry
To resolve this issue, create or modify the MaxPrintersPerSession registry entry to ensure that the maximum number of printers per session limit is not reached. By default, the maximum number of printers per session limit is 20.
To perform this procedure on the terminal server, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
To change the registry entry:
Caution : Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.
  1. On the terminal server, open Registry Editor. To open Registry Editor, click Start, click Run, type regedit, and then click OK.
  2. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  3. Locate the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services registry subkey.
  4. Right-click Terminal Services, point to New, and then click DWORD (32-bit) Value.
  5. Type MaxPrintersPerSession as the entry name, and then press ENTER.
  6. Right-click MaxPrintersPerSession, and then click Modify.
  7. In the Value data box, type the maximum number of printers that you want to allow per session, and then click OK.
  8. Close Registry Editor.
For the settings to take effect, do either of the following:
  • Have the user log off from the session, and then start a new session.
  • Restart the Terminal Services UserMode Port Redirector service on the terminal server.
Use the following procedure to restart the Terminal Services UserMode Port Redirector service on the terminal server.
To perform this procedure on the terminal server, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
To restart the service:
  1. On the terminal server, open the Services snap-in. To open the Services snap-in, click Start, point to Administrative Tools, and then click Services.
  2. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  3. In the Services pane, right-click Terminal Services UserMode Port Redirector, and then click Restart.
  4. Confirm that the Status column for the Terminal Services UserMode Port Redirector service displays Started.
Verify :
To verify that printer redirection is working properly, establish a remote session with the terminal server and check that the redirected printer is available and is functioning as expected.
Reference LinksEvent ID 1124 from Source Microsoft-Windows-TerminalServices-Printers

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