Event ID - 110

Event Id110
SourceESE97
DescriptionMSExchangeDS (988) the database engine has successfully completed recovery steps.
Event Information
According to Microsoft:
CAUSE :
Error -510 corresponds to JET_errLogWriteFail. The error can be caused by a corrupted Edb.log file.
WORKAROUND :
To work around this issue, follow these steps:
1. Backup your current database.
2. Check whether Dir.edb is consistent by using eseutil /mh.
3. Do one of the following:
• If Dir.edb is consistent, remove all log files and start the directory service.
-or-
• If Dir.edb is inconsistent, restore from backup.
4. When you restore from Online Backup, replay only transaction logs older than the corrupted one.
5. When you restore from Offline Backup, empty the database and transaction log directories and restore only Dir.edb.
Reference LinksJET Will Now Retry 16 Times on -1018 Error

How to Determine Which Mailbox Owns a Particular Page in a Database

Directory service does not start, event log shows error -510

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XADM: Recovery May Incorrectly Increment the Checkpoint File

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