Event ID - 1102

Event Id1102
SourceMicrosoft-Windows-TerminalServices-Printers
DescriptionDriver %1 required for printer %2 is not installed on the server. Contact the administrator to install the driver before you log in again.
Event InformationAccording to Microsoft :
Cause :
This event is logged when driver required for printer is not installed on the server.
Resolution :
Reinstall the printer driver or modify a custom printer mapping file
To resolve this issue, do either of the following:
  • Install or reinstall the printer driver on the terminal server.
  • Create or modify a custom printer mapping file.
To perform these tasks, refer to the following sections.
Install or reinstall the printer driver on the terminal server
If the printer driver installed on the client computer is an OEM driver, and a driver is available from the printer's manufacturer, replace the OEM driver with the driver that is available from the printer manufacturer. If you are installing a third-party driver, make sure that the driver is a Windows Hardware Quality Labs (WHQL) signed driver.
Important : After you install the printer driver, terminal server clients must log off and then log on to the terminal server before the printer driver changes take effect.
To install the printer driver, use either of the following methods.
To perform these procedures, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
Method one
Run the printer's Setup program to install the printer driver .inf file on the terminal server.
Method two
To install the driver by using the Add Printer Driver Wizard:
  1. On the terminal server, click Start, click Run, type control printers, and then click OK.
  2. On the File menu, click Server Properties.
    Note : If the File menu is not visible, right-click an empty area of the Printers dialog box, and then click Server Properties.
  3. Click the Drivers tab.
  4. Click Add, and then follow the instructions in the Add Printer Driver Wizard to install the printer driver .inf file.
Create or modify a custom printer mapping file
You can create or modify an existing custom printer mapping file to define mappings from client-side to server-side drivers on the terminal server.
To perform this procedure on the terminal server, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
To use a custom printer mapping file:
Caution : Incorrectly editing the registry might severely damage your system. Before making changes to the registry, you should back up any valued data.
  1. On the terminal server, open Registry Editor. To open Registry Editor, click Start, click Run, type regedit, and then click OK.
  2. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  3. Locate the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd registry subkey.
  4. Add the following values:
    Name: PrinterMappingINFName
    Type: String (REG_SZ)
    Value data: Name of the .inf file to which you want to redirect lookups.
    Example: c:\windows\inf\ntprintsubs.inf
    Name: PrinterMappingINFSection
    Type: String (REG_SZ)
    Value data: Name of the section in the .inf file to which you want to redirect lookups.
    Example: Printers
After you add the new registry values, create or modify the .inf file that you specified in the PrinterMappingINFName registry entry to include the user-defined mappings from the client-side to server-side drivers.
The left side of the equation is the exact name of the printer driver associated with the client-side print queue that is being redirected to the server. The exact name of the printer driver appears on the General tab, next to Model when you view the printer properties on the client computer. (You can also click the Advanced tab and view the driver name in the Driver list.) The right side of the equation is the exact name of the server-side driver equivalent that is installed on the terminal server.
Important : You must restart the Print Spooler service on the terminal server for the changes to take effect.
To perform this procedure on the terminal server, you must have membership in the local Administrators group, or you must have been delegated the appropriate authority.
To restart the Print Spooler service:
  1. On the terminal server, open the Services snap-in. To open the Services snap-in, click Start, point to Administrative Tools, and then click Services.
  2. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
  3. In the Services pane, right-click Print Spooler, and then click Restart.
  4. Confirm that the Status column for the Print Spooler service displays Started.
Verify :
To verify that printer redirection is working properly, establish a remote session with the terminal server and check that the redirected printer is available and is functioning as expected.
Reference LinksEvent ID 1102 from Source Microsoft-Windows-TerminalServices-Printers

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