Event ID - 1010

Event Id1010
SourceMicrosoft-Windows-Diagnosis-PLA
DescriptionCounter %2 could not be added to collector %1, error code is %3.
Event Information According to Microsoft :

Cause :

This event is logged when counter could not be added to collector.

Resolution :

Check data collector

If Performance Logs and Alerts cannot add a data collector to its query, the error message will contain details about the data collector that could not be collected and the reason for the failure. If a four-digit or five-digit Windows Error Code is included, you can find the explanation of the error code on the Web. Use the procedures below to resolve the identified errors.

Membership in the local Administrators group is required to complete these procedures.

View a list of available performance counters on the system

To see a list of available performance counters on the system:
  1. Click Start , click All Programs , and click Accessories .
  2. Right-click Command Promp t and then click Run as administrator .
  3. At the command prompt, type typeperf -qx and then press ENTER.
Delete an invalid data collector from an existing Data Collector Set

To delete an invalid data collector from an existing Data Collector Set:
  1. Click Start , click in the Start Search box, type perfmon.exe , and press ENTER.
  2. In the navigation tree, expand Data Collector Sets , and then expand User Defined .
  3. In the navigation tree, click the name of the Data Collector Set that you want to modify.
  4. In the console pane, right-click the name of the invalid data collector and then click Delete .
Add a data collector to an existing Data Collector Set

To add a data collector to an existing Data Collector Set:
  1. Click Start , click in the Start Search box, type perfmon.exe , and press ENTER.
  2. In the navigation tree, expand Data Collector Sets , and then expand User Defined .
  3. In the navigation tree, right-click the name of the Data Collector Set that you want to modify, point to New , and then click Data collector .
  4. Follow the steps in the wizard to add the data collector.
Verify :

You can use Windows Reliability and Performance Monitor to verify that netowkr performance counters are properly collected and displayed in a Performance Monitor graph. In addition, you can use the typeperf command to get a list of the available counters on the local system.

Membership in the local Administrators group is required to complete these procedures.

View counters in Performance Monitor

To view counters in Performance Monitor:
  1. On the computer where you want to view counters, click Start . In the Start Search text box, type perfmon.exe , and then press ENTER.
  2. In the navigation pane, expand Monitoring Tools , and then click Performance Monitor .
  3. Click the Add button to open a list of available performance counters.
  4. In the Add Counters dialog box, you can click Help for more information on adding counters. When you have finished adding counters to the list, click OK .
  5. Verify that the performance counters you selected are displayed in the Performance Monitor graph.
View a list of counters using the typeperf command

To view a list of counters at the command prompt:
  1. Click Start , click All Programs , and click Accessories . Right-click Command Prompt , and click Run as administrator .
  2. At the command prompt, type typeperf -qx and press ENTER.
  3. Verify that the performance counter list contains expected values.
Reference LinksEvent ID 1010 from Source Microsoft-Windows-Diagnosis-PLA

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