Event ID - 3

Event Id3
SourceMicrosoft-Windows-SpoolerWin32SPL
DescriptionThe print spooler failed to reopen an existing printer connection because it could not read the configuration information from the registry key %1\%2. This can occur if the key name or values are malformed or missing.
Event Information According to Microsoft :

Cause :

This event is logged when the print spooler failed to reopen an existing printer connection because it could not read the configuration information from the registry key.

Resolution :

Retry printing or restart the print spooler

Windows Printing encountered an error; however, it may retry the action or work around the problem. If printing is not working correctly, possible resolutions include:
  • Retry printing.
  • Examine the error code returned by this event. For a list of system error codes and a brief explanation of what they mean, see the Microsoft Web site.
  • Start or restart the Print Spooler service, using the following procedure.
    Warning : Restarting the Print Spooler causes all print jobs to be restarted. After restarting the Print Spooler service, you might need to reset some printers or turn them off and then turn them back on. On an active print server, perform this procedure outside of normal business hours or during scheduled maintenance time, if possible. Before performing this procedure, take all printers offline and wait for all print jobs to becompleted, or pause all printers and wait for all Active print jobs to be completed.

    1. In the Administrative Tools folder, open the Services snap-in.
    2. Locate the Print Spooler service in the list of services, and then confirm that its status is Started . If its status is not Started , select the service and then click Start on the Action menu.
      Note : You can also do this from an elevated Command Prompt window by typing the following command: net stop spooler && net start spooler

    In some instances, you might receive Error 1068 – "The dependency service or group failed to start" – when attempting to start the print spooler. This can happen if the Print Spooler service relies on other services that are not running. To resolve this issue, use the following procedure:

    1. In the Services snap-in, right-click Print Spooler and then click Properties .
    2. Click the Dependencies tab. The first box lists all of the system services that must be running for the Print Spooler to start. These are the dependencies.
    3. Make a note of each service, click OK , and then start each service that the Print Spooler service depends on, if the service is not already started. If a particular service was not already started, right-click it, click Properties , and then confirm that the Startup type is Automatic .
Verify :

Perform the following tasks to verify that you resolved the problem:
  • Confirm that the appropriate print queues are present on the computer and that the printer settings are correct.
  • If Windows was attempting to remove a print queue from the computer, confirm that the queue was deleted or in the process of being deleted. Some print queues cannot be completely deleted until the print spooler or computer is restarted.
  • Print the document again. If the print server logs spooler information events, look for Print Spooler Event 10 after printing, and then examine the document to confirm that it printed correctly.
Reference LinksEvent ID 3 from Source Microsoft-Windows-SpoolerWin32SPL

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